none
Purchase error (doesn't meet minimum system requirements) RRS feed

  • Question

  • My Windows 8 Store app has just been published, and to check it out I went to the Store and tried to install the app.

    It appears OK on the store screen, but when I actually tried to install it, the Store put up this message:

    "Purchase Error
    Sorry, this app can't be installed because your PC doesn't meet the minimum system requirements"

    Other applications on the Store can be installed OK, and I don't believe my app has any special requirements.  The release info is:

    Selling detailsPrice tier: Free
    Category: Books & Reference
    Subcategory: E-reader
    Available as soon it passes certification.
    Minimum DirectX feature level: Available to all systems
    Minimum system RAM: Available to all systems
    Markets: Rest of World, United States, Japan, India, Germany, France, Australia, Austria, Belgium, Brazil, Canada, China, Hong Kong SAR, Ireland, Korea, Luxembourg, Mexico, New Zealand, Russia, Singapore, South Africa, Spain, Sweden, Switzerland, Taiwan, United Kingdom, Algeria, Argentina, Bahrain, Bulgaria, Chile, Colombia, Costa Rica, Croatia, Cyprus, Czech Republic, Denmark, Egypt, Estonia, Finland, Greece, Hungary, Indonesia, Israel, Italy, Jordan, Kazakhstan, Kuwait, Latvia, Lebanon, Libya, Lithuania, Malaysia, Malta, Morocco, Netherlands, Norway, Oman, Pakistan, Peru, Philippines, Poland, Portugal, Qatar, Romania, Saudi Arabia, Serbia, Slovakia, Slovenia, Sri Lanka, Thailand, Trinidad and Tobago, Tunisia, Turkey, Ukraine, United Arab Emirates, Uruguay, Venezuela, Vietnam, Iraq

    The app is 'Freda'.  Link here:

    http://apps.microsoft.com/webpdp/app/freda/fcd5a822-22a7-48e9-8726-eec07c5056fb

    My PC is certainly capable of running the app (it runs just fine, if launched from the debugger).

    Anyone have any ideas what is going on?

    

    


    Jim Chapman


    Thursday, October 25, 2012 8:52 AM

Answers

  • OK - it turns out I can answer my own question.

    The issue was that I had been running the app from the debugger, and I still had the 'in development' version of the app installed on the PC.  Once I had uninstalled that version, the installation from the Store worked fine.  Silly of me really! (in mitigation I plead that this is not how it works on Windows Phone, though why I expected similar behaviour between Windows Phone and Windows 8, I cannot imagine)


    Jim Chapman

    Thursday, October 25, 2012 5:41 PM

All replies

  • OK - it turns out I can answer my own question.

    The issue was that I had been running the app from the debugger, and I still had the 'in development' version of the app installed on the PC.  Once I had uninstalled that version, the installation from the Store worked fine.  Silly of me really! (in mitigation I plead that this is not how it works on Windows Phone, though why I expected similar behaviour between Windows Phone and Windows 8, I cannot imagine)


    Jim Chapman

    Thursday, October 25, 2012 5:41 PM
  • I still can't buy my own app!  ;)  The Windows App Store will only allow US payment options, even though my account is Canadian!  Anyone Else have this issue?
    Thursday, October 25, 2012 6:39 PM