Renumbering the monitors RRS feed

  • Question

  • If this is the incorrect forum, any direction would be greatly appreciated.  My setup: Windows7 x64, 16gig Ram, 256ssd, dual video cards.

    We have workstations with 4 or even 6 monitor configurations.  There is 3D software that we use that is giving us fits.  The software developers came back to us saying that the primary monitor (1 in Windows GUI) needs to be the monitor we are doing 3D from (primary video card).  The primary monitor (1) needs to come off a specific video card (mainly dual card stations).  It doesn't matter the order in Windows.  

    I am very familiar with changing the monitor order in Screen Resolution and this won't work.  If I disconnect all the monitors and start with the primary monitor on the primary card, then add the monitors after that, it reverts back to the original number before I started all my work.

    I found a registry key that looked very promising.  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\monitor\Enum has values that correspond with the GUI numbering.  The values on my test station with dual monitors says: Default, 0, 1, Count, NextInstance.  "0" corresponds with "1" in the Display Settings GUI of Windows.  "1" corresponds with "2" in Windows GUI.  I renamed the keys so that 0 is now 1 and 1 now 0.  Rebooted and the settings go back to pre-modification settings.

    I even tried moving the video card from one slot to another and just turning on the system with the monitor I want as 1 connected.  Once I connected the other monitor, it reverts back.  I even deleted the monitor settings in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration and Connectivity to no avail.

    Is there any way to get Windows to reassign the display numbering?  I know this sounds crazy, but this is what the developer is telling us.  Knowing the history with this developer, I'm sure it will work if I can get the workstation to use 1 and 2 from the primary video card.

    Wednesday, March 14, 2018 2:54 PM