locked
Custom Code Security Setting RRS feed

  • Question

  • I am using custom code in couple of my SSRS reports. I can view the output on report manager, but in my BI development studio it shows me an error "An error occured during local report processing".

    I tried all the possible options to resolve the issue. I am adding the references of the assemblies System.Data and System.XML. Also i referred the article http://support.microsoft.com/kb/842419/en-us and tried all the steps to modify the code access security for custom assembly.

    I am clueless as in what to do next.

    Thanks,
    Chaitali

    Friday, September 3, 2010 3:04 PM

Answers

  • Hi Chaitali,

    As you said, the issue may be caused by the custom code security settings. In SQL Server Reporting Services(SSRS), we need to configure the custom code security settings in rssrvpolicy.config and rsmgrpolicy.config. In Business Intelligence Development Studio(BIDS), we need to configure the custom code security settings in RSPreviewPolicy.config. This file is located in C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\RSPreviewPolicy.config by default.

    We need to add the code group for the custom assembly in this configuration file.

    As a temporary workaround, we can change the following code in RSPreviewPolicy.config to be FullTrust:
    <CodeGroup
                                    class="FirstMatchCodeGroup"
                                    version="1"
                                    PermissionSetName="FullTrust"
                                    Description="This code group grants MyComputer code Execution permission. ">

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    • Marked as answer by Chaitali Barve Tuesday, September 7, 2010 1:56 PM
    Monday, September 6, 2010 12:09 PM

All replies

  • Hi Chaitali,

    As you said, the issue may be caused by the custom code security settings. In SQL Server Reporting Services(SSRS), we need to configure the custom code security settings in rssrvpolicy.config and rsmgrpolicy.config. In Business Intelligence Development Studio(BIDS), we need to configure the custom code security settings in RSPreviewPolicy.config. This file is located in C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\RSPreviewPolicy.config by default.

    We need to add the code group for the custom assembly in this configuration file.

    As a temporary workaround, we can change the following code in RSPreviewPolicy.config to be FullTrust:
    <CodeGroup
                                    class="FirstMatchCodeGroup"
                                    version="1"
                                    PermissionSetName="FullTrust"
                                    Description="This code group grants MyComputer code Execution permission. ">

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    • Marked as answer by Chaitali Barve Tuesday, September 7, 2010 1:56 PM
    Monday, September 6, 2010 12:09 PM
  • Thanks so much Jin.

    I had tried changing most of the Permission Set Name to Fulltrust, i dont know why this one was skipped.

    But now i know what makes it works.

    Thanks again for your help, I appreciate it.

     

    Thanks,

    Chaitali

    Tuesday, September 7, 2010 1:55 PM