none
Azure Sphere Tenant Create Fails RRS feed

  • Question

  • I am unable to create an Azure Sphere tenant. When I try I get the error below:

    azsphere tenant create --name "Azure Sphere"
    error: Failed to create an Azure Sphere tenant with name 'Azure Sphere'.
    Trace ID: 77c5fb22-e445-4bc9-9414-f506e602f195
    error: An unexpected problem occurred. Please try again; if the issue persists, please refer to aka.ms/azurespheresupport for troubleshooting suggestions and support.
    error: Command failed in 00:00:40.1452652.

    I have looked at other reports of this issue here and have tried other commands to gather more information which are below:

    azsphere show-version
    19.05
    Command completed successfully in 00:00:00.4565359.

    azsphere device show-ota-status
    warn: No Azure Sphere tenants found under the selected AAD user.
    warn: Use 'azsphere login' to change AAD user, or create a new Azure Sphere tenant using 'azsphere tenant create'.
    error: Command failed in 00:00:02.1728911.

    azsphere tenant list
    warn: No Azure Sphere tenants found under the selected AAD user.
    warn: Use 'azsphere login' to change AAD user, or create a new Azure Sphere tenant using 'azsphere tenant create'.
    error: You do not have access to any Azure Sphere tenants.
    error: Command failed in 00:00:02.2852490.

    I can see if I look in my AAD that I have the 2 Azure Sphere Applications (API and Utility) listed.

    The account I am using to try and create the tenant has the Global Admin role

    Any help with this appreciated.

    Sunday, September 8, 2019 6:32 PM

All replies

  • @Peter Jestico

    Please refer the suggestions outlined in the similar MSDN thread and let us know if it helps to resolve the issue.

    Monday, September 9, 2019 4:42 AM
    Moderator
  • I have reviewed and don't see how this helps.

    I haven't created a tenant anywhere else using this device and I haven't claimed this device anywhere else.

    Monday, September 9, 2019 9:19 AM
  • Does anyone have a view as to what the issue could be here?

    Is it a faulty device which requires an RMA or is there is a different issue here?

    If its an RMA then there is clock ticking on that I assume.

    Tuesday, September 10, 2019 9:04 AM
  • I'm still hoping someone from Microsoft can pick this up and progress it
    Wednesday, September 11, 2019 8:57 AM
  • @Peter Jestico

    Please try to recover the device by using the below command.

    azsphere device recover

    Once device is recovered, you can follow the steps again to Install Azure Sphere.

    Let us know if that works.

    Wednesday, September 11, 2019 11:34 AM
    Moderator
  • Thanks for the suggestion, I have already tried that and no change in result
    Wednesday, September 11, 2019 3:15 PM
  • Is there any further assistance that Microsoft can provide here?

    I appreciate these devices are early release but without adequate logging of errors to allow developers and organisations to self solve this product is a very long way from being suitable for Production use.

    At the moment I am in a state of total failure with no support with a brand new unboxed device.
    The issues that will be encountered once a device goes into the field don't bare thinking about if this cant be logged, diagnosed and resolved.

    Wednesday, September 18, 2019 1:09 PM
  • Sorry for the inconvenience caused in this regard. We would like to inform you that, we have received your email and we are checking on this internally. We will update you as earliest.

    Thanks for your time and patience.

     
    Thursday, September 19, 2019 11:11 AM
    Moderator
  • For future reference hoping to help people coming across this thread looking for help:

    This error happens if the device was used to create a tenant. Even though the device haven't been claimed yet.

    Thanks,

    Monday, October 14, 2019 9:37 PM
    Owner