none
Azure Akamai CDN HTTPS endpoint content not being purged

    Question

  • Hi everyone.

    I created a static website using Azure Storage static website and used Azure CDN (Akamai) to have a custom domain and an https endpoint.

    The problem is I can't purge the content on the https endpoint. I upload new content and purge the cache according to the documentation. It works for the http endpoint, but not for the https.

    Is there a specific procedure to purge the cache of the https endpoint?


    Friday, March 1, 2019 8:45 AM

All replies

  • Hi , 

    I did a lab repro with the same config which you have mentioned. It works fine for me. Only difference what I felt is that when you use Akamai, you will not be able to purge using wildcard. 

    I had a static page with default page site.html. I created a CDN profile and added this static page as the origin. Then I created a Custom Domain and mapped it to CDN and enabled only HTTPS endpoint. 

    When I edited the blob , the changes are not reflecting. Then I did a Purge with "/" and then I can see the edited page. 

    Let me know if you have any further questions. 

    Regards, 

    Msrini

    Monday, March 4, 2019 7:00 AM
    Moderator
  • Hi, 

    Do you have any update for me on this thread?

    Let me know if you have any further questions. 

    Regards, 

    Msrini

    Wednesday, March 6, 2019 8:43 AM
    Moderator
  • Hi, 

    Any update on this issue? If the proposed answer helped please remember to mark it as the answer so others who encounter a similar issue can easily find the solution. 

    Regards, 

    Msrini

    Monday, March 18, 2019 9:22 AM
    Moderator