none
SMB client gets "not ready" error when mounting a share from Windows Server 2012 RRS feed

  • Question

  • If this isn't the right forum for this question, please let me know.

    I am encountering a problem when I try to mount a share from my Windows Server 2012.  I am mounting a non-NTFS file system on a Windows Server 2012.  I map the volume to drive letter z: then share the whole volume with full permissions for everyone.  I then try to connect to the share from a Windows 7 SMB client.  I get an error: "The device is not ready".  I run Wireshark to look at the actual SMB error: STATUS_VOLUME_DISMOUNTED.    On the Windows Server 2012 system, I can use Windows Explorer to look at the files on z: and create new files. 

    I tried using Windows Server 2008 and Window Server 2008 R2 as the SMB client and get the same failure.  I try XP and that works.  I run Process Monitor (procmon.exe) on the Windows Server 2012 system.  Suddenly, all these SMB client systems can success mount the share.  I stop running procmon, and I get the same failure as before.

    I tried this on another Windows Server 2012 system and everything works.  I am able to mount the shared file system on the same Windows 7 SMB client that I used in the previous test.

    I looked in the event viewer for any events indicating a mounting failure - I did not see anything.  Any suggestion what extra debug I can turn on to see why the SMB server thinks the volume is dismounted?


    • Edited by Ed Winn Monday, October 28, 2013 9:11 PM
    Monday, October 28, 2013 9:10 PM

Answers