locked
Can't create .APK file after upgrade to Visual Studio 2015 Enterprise Update 3 RRS feed

  • Question

  • User140054 posted

    I am running Xamarin 4.0.4.4 and Xamarin.Android 6.0.4.0. This all worked in Visual Studio 2013. In fact, I'm now trying to upload version 2 of my Android app to Google Play.

    This was an issue, but doesn't fix the problem. https://forums.xamarin.com/discussion/19772/zipalign-error-executing-tool-executable-location-invalid-android-sdk-tools-23

    Tools - Android - Publish Android app produces this error "Packaging failed. Could not create the Android package."

    Build - Export Android Package runs, but it does not create the apk file.

    Is anyone else having issues? I am using these instructions. https://developer.xamarin.com/guides/android/deployment,testing,andmetrics/publishinganapplication/part1-preparinganapplicationforrelease/

    Any help is much appreciated. Thanks!

    Saturday, August 27, 2016 6:18 PM

All replies

  • User140054 posted

    OK, I found the problem. Even through I had unchecked "Bundle assemblies into native code", it was set to True in the csproj file. To solve the problem, I unloaded the Project and then did a right click on the Project and selected edit csproj. I then found the line <BundleAssemblies>True</BundleAssemblies> and set it to False. I saved the file and reloaded the Project. I then ran another Release Build and selected Tools - Android - Publish Android app and that worked. The bug was reported here by @BrendanZagaeski and has never been fixed. https://bugzilla.xamarin.com/show_bug.cgi

    Sunday, August 28, 2016 5:55 PM