none
Error when creating incoming connection Windows 7 Embedded RRS feed

  • Question

  • Hi,

    I am getting this error "An internal error has occurred: The local user database handle is corrupt" when trying to create an incoming connection in Windows 7 Embedded. I have just installed the Windows 7 Embedded trial Evaluation from the Install CD using the Application Compatibility Template. I have re-installed it several times, no difference. I have used another template (Thin Client template), same problem. Does anyone know how to resolve this? Many Thanks

    Wednesday, June 11, 2014 7:22 AM

All replies

  • I don't know this link is suitable or not, but you can refer it. 

    http://social.msdn.microsoft.com/Forums/en-US/5c9a9333-b9ee-4743-a91d-f7fb4bb260eb/cannot-create-an-incoming-connection-on-windows-embedded-standard-7-image?forum=quebeccomponentsforum

    Wednesday, June 11, 2014 8:24 AM
  • Yea I have come across that link and I gave up when I realised that I could not blank the registry value. I will give this another go as it seems to be the only viable solution... 

    Thanks

    Wednesday, June 11, 2014 9:00 AM
  • It seems somethings wrong happen in your trial evaluation. You can contact with your dist for the WES7 OPK. Maybe it will be solved.
    Wednesday, June 11, 2014 9:30 AM
  • The other thread mentioned booting PE in order to make the registry changes. Here's where I am:
    1. Boot to PE - done
    2. Open Regedit - done
    3. Select Users - done
    4. Load Hive - done
    5. C:\windows\system32\config\software - done

    At this stage I am prompted for a key. I have entered: "{48da6741-1bf0-4a44-8325-293086c79077}", created the DllSurrogate entry, left it blank

    1. Unload hive - done
    2. Reboot  - done

    Tried creating an incoming connection, no difference, same error. Any idea?

    Thanks.

    Wednesday, June 11, 2014 1:30 PM
  • I have finally cracked it. In case anyone else has the same issue, the instructions weren't far off:

    1. Boot to PE
    2. Open regedit
    3. Select Local Machine
    4. Load Hive
    5. Select C:\windows\system32\config\software 
    6. When prompted enter any name .e.g OfflineSoftware
    7. Locate the key, under Software\Classes\AppID
    8. Make the changes
    9. Collapse the hive and unload it
    10. Restart

    Done.

    Thanks


    • Edited by DiddyPerl Wednesday, June 11, 2014 3:24 PM Precision
    Wednesday, June 11, 2014 2:51 PM
  • You do not have to start in a PE, you can take ownership of the registry key also easy.
    After a Sysprep the problem is the way possibly back.

    Oh and this problem is know by Microsoft more thank 3 years now, my Embedded Distributor know this problem, but MS dont solve it, it stay at point 4xx at MS Working list for patches......

    • Edited by knutschie Wednesday, June 18, 2014 6:23 AM
    Wednesday, June 18, 2014 6:21 AM
  • Ok, good to know. Cheers.
    Wednesday, June 18, 2014 8:19 AM