locked
WP8 SDK install - Setup Blocked: The computer needs to be restarted RRS feed

  • Question

  • Can't find an answer for this one here.

    64-bit PC. Visual Studio 12. Already develop Windows Store apps. But can't install WP8 SDK...it says "Setup Blocked" and "The computer needs to be restarted before setup can continue. Please restart the computer and run setup again."

    I've restarted several times and can never get this installed. What's up?


    Jay in Atlanta

    Sunday, February 17, 2013 7:53 PM

Answers

  • For me, the answer for this was to reboot at least once more. After at least one more reboot, the error message was different and clearer: it was a disk space warning given that the tools take 5+ GB. So, reboot again, free up a bit more storage space and it worked fine.

    Jay in Atlanta

    • Marked as answer by jayinatlanta Tuesday, February 19, 2013 1:11 AM
    Tuesday, February 19, 2013 1:11 AM

All replies

  • For me, the answer for this was to reboot at least once more. After at least one more reboot, the error message was different and clearer: it was a disk space warning given that the tools take 5+ GB. So, reboot again, free up a bit more storage space and it worked fine.

    Jay in Atlanta

    • Marked as answer by jayinatlanta Tuesday, February 19, 2013 1:11 AM
    Tuesday, February 19, 2013 1:11 AM
  • You should open Task Manager then find Windows Installer and Windows Installer 32 bit. You have to End Task them all. You must be sure they are closed. Moreover, you can click setup it again by 'WPexpress_full.exe'.
    Friday, May 3, 2013 2:52 PM
  • Hi Jay,

    I have VS 2012 Ultimate which runs on Windows 8 Ultimate
    and I wanted to install Windows Phone 8 SDK using WPExpress_full.exe
    I ran into the same issue and managed to solve it.

    In my case I did a computer restart with an update. The system update ran properly
    and I then could go on with the installation process without any
    "Setup Blocked: The computer needs to be restarted" - message.

    At one point however during the installation process, I was prompted to install Win8SharedSDKTools.msi file. 
    I had the choice between
    1) downloading the Win8SharedSDKTools.msi file from the internet or
    2) select a local file included in the ISO packages - wpsdkv80_enu1/packages/Windows_SDK.
        which I didn't have then...

    First option to download the Win8SharedSDKTools.msi file from the internet didn't work in my case...
    So I decided to remove everything and repeat the installation process over again
    but this time using the ISO [files and packages].

    I then ran into an issue saying the timestamp of Win8SharedSDKTools.msi 
    and cab files included in the ISO package were outdated. Aaaaaaargh!
    Some have suggested in other threads to modify the system date to an earlier date... 
    PLEASE DON'T ...I don't believe that it's a clever but rather risky solution...

    Instead it's better to download and replace the outdated with the updated files version from

    http://support.microsoft.com/kb/2897627/en-gb


    I uninstalled the Windows Phone 8 SDK for a nth time... and I proceeded in
    1)first installing Win8SharedSDKTools.msi.
    2)I then re-run Windows Phone SDK 8.0 setup as normal

     Luckily everything got installed properly this time ...

    Patience is the key my friends... looooooot of patience... 

    BTW has anyone used Windows Phone 8 Hyper-V emulator on Windows 8.1?

    Just want to check before making the move ;)

    Friday, October 11, 2013 4:09 PM
  • Jay, you are probably way past this issue, but for anyone else who may just be jumping onto the thread like I was earlier today, here's something I found out - after much frustration. Shutting down the computer and starting it up again is not the same thing as a restart, at least not in the context of the VS install (ridiculous). From the Charm menu you have to select "Restart" rather than doing "Shut Down" and then starting it up yourself. 

    You should be in business after that.

    Friday, August 22, 2014 3:06 PM