locked
Error during Publish Compability RRS feed

  • Question

  • User1707710898 posted

    Hi,

    I am trying to publish a site using WebMatrix 3. I am trying to publish this site to my VPS, where I have installed and configured IIS. On the VPS I have published my Site and created a *.publishsettings file, which I am using in WebMatrix.

    When I use this file, the validation works fine, however when I reach the "Publish Compability" test, then the Simple HTML Page test fails and writes "Not available". 

    Then only information returned is to check the Destionation URL, but since this comes from the *.publishsettings file, I am pretty sure it is correct.

    Is it possible to get more information, get some error log, or somehow debug this, so to find what is causing this error? I have tried to Google this, but apparently I am using the wrong keywords because I cant find anything useful.

    Best regards and thank you in advance!

    Andreas 

    Monday, June 3, 2013 3:54 PM

Answers

  • User1707710898 posted

    I managed to get the Publishing working, even though the Simple HTML Page Test failed. No extra steps was taken, perhaps the server was rebooted. 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, June 18, 2013 3:03 PM

All replies

  • User1713851783 posted

    Have you already published your domain on the DNS system?

    If not, insert it in the hosts file of your computer and try again.

    Monday, June 3, 2013 4:19 PM
  • User1707710898 posted

    Hi, 

    Thanks for your reply.

    I am not sure what you mean. The DNS points to the right server, as in I can type mywebsite.com in my browser and I get my IIS splashscreen? 

    Is this what you mean?

    Monday, June 3, 2013 4:40 PM
  • User1713851783 posted

    If you type www.mywebsite.com on your browser you have your IIS splashscreen, but maybe your Webmatrix site has another address, something like another.mywebsite.com. Is this second address public?

    Monday, June 3, 2013 4:54 PM
  • User-821857111 posted

    You should ask questions about publishing with WebMatrix here: http://forums.iis.net/1166.aspx

    Tuesday, June 4, 2013 1:34 AM
  • User1707710898 posted

    I managed to get the Publishing working, even though the Simple HTML Page Test failed. No extra steps was taken, perhaps the server was rebooted. 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, June 18, 2013 3:03 PM