none
Error in WCF-WSHttp Adapter RRS feed

  • Question

  • I have exposed schemas as WCF Service using WCF publishing wizard. It has created a service and receive location. The account under which the isolated host is running has all the access to BizTalk databases. The Service is also running under the App Pool of same account. The receive location enabled. But when we browse the URL, it throws the error

    The Messaging Engine failed to register the adapter for "WCF-WSHttp" for the receive location "/Sample/Sample.svc". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Runtime.InteropServices.COMException: The Messaging Engine failed to register the adapter for "WCF-WSHttp" for the receive location "/Sample/Sample.svc". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [COMException (0xc0c01666): The Messaging Engine failed to register the adapter for "WCF-WSHttp" for the receive location "/Sample/Sample.svc". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases. ]
       Microsoft.BizTalk.TransportProxy.Interop.IBTTransportProxy.RegisterIsolatedReceiver(String url, IBTTransportConfig callBack) +0
       Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfIsolatedReceiver`2.RegisterIsolatedReceiver(Uri uri) +360
    
    [AdapterException: Failed to register isolated receiver for address /Sample/Sample.svc"; receive location does not exist or is disabled.]
       Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfIsolatedReceiver`2.RegisterIsolatedReceiver(Uri uri) +937
       Microsoft.BizTalk.Adapter.Wcf.Runtime.WebServiceHostFactory`3.CreateServiceHost(String constructorString, Uri[] baseAddresses) +382
       System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath) +604
       System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +46
       System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +654
    
    [ServiceActivationException: The service '/Sample/Sample.svc' cannot be activated due to an exception during compilation.  The exception message is: Failed to register isolated receiver for address /Sample/Sample.svc"; receive location does not exist or is disabled..]
       System.ServiceModel.AsyncResult.End(IAsyncResult result) +15626160
       System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +15546201
       System.ServiceModel.Activation.HostedHttpRequestAsyncResult.ExecuteSynchronous(HttpApplication context, Boolean flowContext) +265
       System.ServiceModel.Activation.HttpModule.ProcessRequest(Object sender, EventArgs e) +227
       System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +80
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +171
    

    Please let me know what needs to be done.

    Thanks and Regards
    Raci
    • Moved by Ben Cline1Moderator Thursday, October 22, 2009 3:36 PM Related to adapters (From:BizTalk Server General)
    Thursday, October 22, 2009 9:51 AM

All replies

  • Wade Wegner said he resolved it by adding read/write access to the isolated host service account to c:\Windows\Temp. See his post at http://blog.wadewegner.com/index.php/category/wcf/ for more. Give it a try.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Thursday, October 22, 2009 7:38 PM
    Moderator
  • Thank you Ben.. I tried the above but it is still not working.

    Regards
    Raci
    Monday, October 26, 2009 5:52 AM
  • Hi Raci,

    If the isolated host are marked as 'Trusted', please temporarily disable the option and then test again. This can also be a possible reason of this error because the host trusted options require additional settings (e.g. client certificates / party resolution) for BizTalk to authenticate the sender.

    Thanks.


    Sincerely WenJun Zhang - MSFT Microsoft Online Community Support Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 29, 2009 8:00 AM
    Moderator
  • Is the receive location configured with the WCF-WSHttp adapter, and does the address in the receive location match the address of the web service?
    Thiago Almeida - http://connectedthoughts.wordpress.com
    Thursday, November 5, 2009 9:19 PM
  • Hi,

    Please make sure the following points it would definitely work, as it is working for me now:

    1. If you are using anontmous access then use WCF-BasicHttp  instead of WCF-WsHttp
    2. Make sure the identity of the application pool is configured to run under IWAM_<Machine name>
    3. Make sure the web site under which the service comes has anonymous access enabled and proper password is set.
    4. Make sure the web application (application name) under which the service runs has anonymous access enabled and proper password is set.
    5. Make sure that c:\windows\temp can be read and written by IWAM_<Machine name> as well as IUSR_<Machine name>
    6. Make sure that IWAM_<Machine name> is a member of both IIS_WPG and Isolated Host Users.

    If all the above points are taken care of it would definitely work, but please issue an iisreset after tinkering with inetmgr.

    Please mark as answer if this helps you. Thanks and warm regards Ambar Ray EAI Architect - Microsoft Technologies
    • Proposed as answer by Ambar Ray Friday, November 6, 2009 5:30 AM
    Friday, November 6, 2009 5:30 AM
  • I solved this problem by making sure that the AppPool that my BizTalk web service running under was the same account as the Isolated Host Instance.
    Monday, June 28, 2010 7:34 PM