locked
RTM Known Issue: Visual Studio 2015 may show a dialog box to enable developer mode with a wrong message or not show a dialog box at all when creating a Universal Windows app or Windows 8.1 app RRS feed

  • Question

  • If you have the “Sideload apps” option selected in the “For Developers” Windows settings, you may notice that when you create a Universal Windows app or Windows 8.1 app using Visual Studio 2015:

    1. A dialog box is displayed which states “This device is already in developer mode” (the message is wrong)

       

       

    2. You do not see any prompt to enable Developer mode

    While either case does not prevent you from creating apps, the behavior and messaging is inconsistent.


    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog





    Friday, September 4, 2015 9:01 PM
    Moderator

Answers

  • You may run into this issue if you have upgraded your system from Windows 8.1 to Windows 10 AND your old Windows 8.1 system had a “Developer license” installed on it. To resolve this problem, you will need to remove the old developer license by running the following cmdlet from an Elevated Powershell prompt: “Unregister-WindowsDeveloperLicense” (without quotes). Following this, you will have to choose “Developer Mode” radio button from the “For developers” Settings screen to enable developer mode again on your Windows 10 system. You can reach this setting by clicking the “settings for developers” link in the above dialog box.

    Please reference the following link to understand what the various developer modes mean: https://msdn.microsoft.com/en-us/library/windows/apps/dn706236.aspx#WhichSettings

    Note: This issue will not happen if you are upgrading from Windows 7 to Windows 10 or if you have freshly installed Windows 10 RTM.


    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog

    Friday, September 4, 2015 9:03 PM
    Moderator