locked
Xamarin.Forms: App runs in simulator and on device, however it freezes on iOS devices RRS feed

  • Question

  • User128118 posted

    Hi Xamarin!

    When I try to launch my Xamarin Forms app with the debugger attached, the app just hangs at the splash screen. However, if I kill the debugger and just launch the app directly by tapping on it, it opens and runs just fine on all my iOS devices (as well as the simulators). I'm basically unable to debug my app now from the device. I have tried rebooting my mac, the devices, cleaning the build, deleting all obj/bin folders, etc.. Nothing works.

    The device logs show the following errors in relation to my app but they don't mean anything to me:

    Error (52) / SpringBoard(SplashBoard): [com.TUE] Failed to generate image for

    Error (62) / assertiond: [TUE.iOS:286] SyscallError: setpriority(PRIODARWINROLE, 286, 3): No such process

    The first error, I only saw it once but the PRIODARWINROLE ONE I see it every time. I

    Is there something else I can do to troubleshoot this? I'm using VS for Mac (the latest version).

    Monday, March 9, 2020 10:57 PM

All replies

  • User74 posted

    Strange, have you tried deleting the app from the device as well?

    Tuesday, March 10, 2020 6:00 AM
  • User128118 posted

    Yes, I've deleted from the device.

    Tuesday, March 10, 2020 1:43 PM