none
Migration of Custom Assembler component from BizTalk server 2006 to 2009 RRS feed

  • Question

  • Hi,

    I am using an custom Assembler component in the Send pipeline of my BizTalk server 2006 project. Now I have to migrate it to BizTalk server 2009. I believe in 2006 we have HIPPA assembler and in 2009 it is an EDI assembler. Could you please suggest me whether I can use the same assembler component in BizTalk server 2009 or the custom Assembler component in 2009 will be different from the one in BizTalk server 2006.

    Thanks,
    R.Subha

    • Moved by Ben Cline1Moderator Friday, August 28, 2009 2:50 PM This is an EDI question. (From:BizTalk Server Adapters and Adapter Pack)
    Thursday, August 27, 2009 12:42 AM

Answers

  • Hi,

    I have solved the issue by using "EdiAssembler" instead of "HipaaAsm". This needs "Microsoft.BizTalk.Edi.Pipelines" as reference.

    Thanks and Regards,
    R.Subha
    • Marked as answer by RSubha Friday, October 9, 2009 8:14 PM
    Friday, October 9, 2009 8:14 PM

All replies

  • correct me if my understood wrong.

    You want to use Hipaa Assembler in BTS 2009. I believe your BTS 2009 box doesn't have Hipaa services.
    If so then you have to install HIPAA Accelerator 3.3 on BTS 2006/R2. Then upgrade your BTS older version to 2009 with HIPAA services.


    Thanks, Raja
    Saturday, August 29, 2009 3:35 AM
  • Hi,

    We have installed the HIPPA accelerator in BTS 2009. But instead of using the built in EDI assembler in the send pipeline, I want to use a custom EDI assembler component. In BTS 2006, we are using the custom HIPPA component to update some information in the X12 file. I want to use the same component in BTS 2009 too. Please let me know whether there is any difference between the custom HIPPA assembler in 2006 and the Custom EDI Assembler in BTS 2009.

    Thanks,
    R.Subha
    Monday, August 31, 2009 3:41 AM
  • Did you find out any issue when you migrate your custom HIPAA component from 2006 to 2009?
    I
    Thanks, Raja
    Tuesday, September 1, 2009 4:07 PM
  • Hi,

    I couldn't use the DLL "Microsoft.Solutions.BTAHIPAA.PipelineComponents" in 2009 which is the namespace for "HipaaAsm". Hence I am not able to use the "Assemble" Method too.

    Thanks and Regards,
    R.Subha
    Thursday, September 24, 2009 10:23 PM
  • Are you using 64 bit environment? If yes could you try your application on 32 bit?
    Thanks, Raja
    Friday, September 25, 2009 2:26 AM
  • Hi,

    I have solved the issue by using "EdiAssembler" instead of "HipaaAsm". This needs "Microsoft.BizTalk.Edi.Pipelines" as reference.

    Thanks and Regards,
    R.Subha
    • Marked as answer by RSubha Friday, October 9, 2009 8:14 PM
    Friday, October 9, 2009 8:14 PM