locked
Issues while adding large dataset to the session configured in app fabric cache session store provider RRS feed

  • Question

  • Hi,

    I am stuck with this issue for a few days and cannot get the solution and it is driving me nuts . Please Help !!

    Scenario

    I get data from the table storage and create a dataset. Say this dataset contains 95 columns and 1000 rows.

    DataSet ds = CreateDataSet(MainTableList); //This method creates the dataset

    Session.Add("TableData",ds); // Add to the session . This is configured in the appfabric data cache

    Issue

    The page goes through the entire life cycle events without any errors. After that there is no response in the browser for several seconds and then I come up with this error. "an existing connection was forcibly closed by the remote host"

    Web.Config Settings

     <dataCacheClients>
        <dataCacheClient name="default" channelOpenTimeout="20000" maxConnectionsToServer="4">
          <localCache isEnabled="true" sync="TimeoutBased" ttlValue="300" objectCount="10000"/>
          <clientNotification pollInterval="300" maxQueueLength="10000"/>
          <hosts>
            <host name="konectcacheeu.cache.windows.net" cachePort="22233"/>
          </hosts>
          <securityProperties mode="Message">
            <messageSecurity authorizationInfo="xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"/>
          </securityProperties>
          <transportProperties connectionBufferSize="131072" maxBufferPoolSize="268435456" maxBufferSize="8388608" maxOutputDelay="2" channelInitializationTimeout="60000" receiveTimeout="45000"/>
        </dataCacheClient>
        <dataCacheClient name="SslEndpoint" channelOpenTimeout="20000" maxConnectionsToServer="4">
          <localCache isEnabled="true" sync="TimeoutBased" ttlValue="300" objectCount="10000"/>
          <clientNotification pollInterval="300" maxQueueLength="10000"/>
          <hosts>
            <host name="konectcacheeu.cache.windows.net" cachePort="22243"/>
          </hosts>
          <securityProperties mode="Message" sslEnabled="true">
            <messageSecurity authorizationInfo="xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"/>
          </securityProperties>
          <transportProperties connectionBufferSize="131072" maxBufferPoolSize="268435456" maxBufferSize="8388608" maxOutputDelay="2" channelInitializationTimeout="60000" receiveTimeout="45000"/>
        </dataCacheClient>
      </dataCacheClients>

    Please note that the above settings might be messed up now as I have been trying several options after reading from forums in the last few days.

    Please let me know how can I resolve this issue !! Thanks a lot for your help in advance !!!

    Thanks!!

    Tuesday, February 7, 2012 11:02 AM

Answers

  • Did you try increasing the timeout of DataCacheClient?

    <dataCacheClient name="default" channelOpenTimeout="20000" maxConnectionsToServer="4" requestTimeout="30000">

    Also, if you are trying this application on Emulator i would suggest to deploy to Windows Azure and see if you get that error. The reason for timeout might be an additional latency from local emulator to the appfabric cache which would be neglisible from Azure VM.

    Hope this helps.

    • Marked as answer by Arwind - MSFT Friday, February 17, 2012 2:58 AM
    Tuesday, February 14, 2012 5:34 PM

All replies

  • Hi,

    Looking at the error, I think that the issue is with the connectionBufferSize/maxbuffersize values in the configuration. Did you tried running after increasing these values.


    If you found this post useful, Please "Mark as Answer" or "Vote as Helpful". Thanks! Vaibhav Gujral.

    Tuesday, February 7, 2012 11:59 AM
  • Thanks Vaibhav,

     I tried setting the connectionBufferSize/maxbuffersize values to 47483647 . Now I dont get the "an existing connection was forcibly closed by the remote host" error anymore. I get the the error "ErrorCode<ERRCA0018>:SubStatus<ES0001>:The request timed out." after several seconds wait.

    I am trying to change the time out values. Meanwhile if anyone has any ideas please let me know!!

    Thanks !! 

    Tuesday, February 7, 2012 2:59 PM
  • Anyone please !!
    Tuesday, February 7, 2012 4:21 PM
  • Hi,

    try to fix "ErrorCode<ERRCA0018>:SubStatus<ES0001>:The request timed out."  error by following links:

    http://explore-software.blogspot.com/2011/10/windows-azure-appfabric-caching-service.html

    http://social.msdn.microsoft.com/Forums/en-US/velocity/thread/9156898a-2ab8-4128-bddb-016da7351103

    Hope it can help you.


    Please mark the replies as answers if they help or unmark if not. If you have any feedback about my replies, please contact msdnmg@microsoft.com Microsoft One Code Framework

    Wednesday, February 8, 2012 6:46 AM
  • I am frustrated. No matter what i do cant get this resolved. There no proper help or documentation about this. Very very frustrating .
    Monday, February 13, 2012 12:52 PM
  • Did you try increasing the timeout of DataCacheClient?

    <dataCacheClient name="default" channelOpenTimeout="20000" maxConnectionsToServer="4" requestTimeout="30000">

    Also, if you are trying this application on Emulator i would suggest to deploy to Windows Azure and see if you get that error. The reason for timeout might be an additional latency from local emulator to the appfabric cache which would be neglisible from Azure VM.

    Hope this helps.

    • Marked as answer by Arwind - MSFT Friday, February 17, 2012 2:58 AM
    Tuesday, February 14, 2012 5:34 PM