locked
tfignore not working in VS 2013 RRS feed

  • Question

  • I'm using Visual studio 2013 with TFS 2013. I've been trying to get all files in a folder to not checkin using .tfignore and with hours of searching and trying different solutions with no luck. I followed the instructionshttp://msdn.microsoft.com/en-us/library/vstudio/ms245454.aspx and could not get it to work. Any help is appreciated.

    My project structure looks something along the lines of:

    • project
      • Controls
      • TestIgnore
        • Class1.cs
        • Class2.cs
      • .tfignore

    and my .tfignore has 1 line of code: \TestIgnore

    My workspace is set to local.

    When I make changes to Class1.cs, when I check in, Class1.cs is in the pending check in list which I believe it should not.

    Friday, August 8, 2014 4:05 PM

Answers

  • Hi VKom,

    I have tried on my own machine with VS2013, and have the same issue as you mentioned. Even the workaround mentioned in this link doesn't help. For this issue, please submit it to Microsoft Connect Feedback portal at: https://connect.microsoft.com/VisualStudio. Microsoft engineers will evaluate it seriously. Please update the link here after submitting the feedback.

    If you don't want to check in files in a specific folder, you can exclude the folder when check in. Another option is use VS 2012 which has the ignore feature if possible.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by VKom Monday, August 18, 2014 3:09 PM
    Tuesday, August 12, 2014 7:56 AM
    Moderator