locked
sql server 2014 AlwaysON issue RRS feed

  • Question

  • Hi:

    I am configuring AlwaysON availability groups with one primary and one replica, on 2014 server

    things I am done with:
    - both the systems are in windows cluster
    - Cluster service is on on both the servers
    - Enabled AlwaysOn from COnfiguration Manager.
    - Hadr_endpoint on port 5022 is STARTED.

    In the Listener Tab, I am choosing the option 'Create an Availablity Group' and I am using the DHCP network mode, port 1433.

    I am not using static IP

    I get the following error:

    Failed to join the database 'DB1' to the availability group 'AG01' on the availability replica 'Server2'. (Microsoft.SqlServer.Smo)
    An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)
    The connection to the primary replica is not active.  The command cannot be processed. (Microsoft SQL Server, Error: 35250)

    Wednesday, August 13, 2014 8:08 AM

Answers

  • can you try to see,is that works?

    http://mssqlwiki.com/2013/06/20/the-connection-to-the-primary-replica-is-not-active-the-command-cannot-be-processed/

    http://blogs.msdn.com/b/alwaysonpro/archive/2013/12/09/trouble-shoot-error.aspx
    http://sqlserver-help.com/tag/the-connection-to-the-primary-replica-is-not-active-the-command-cannot-be-processed/


    Thanks, Rama Udaya.K (http://rama38udaya.wordpress.com) ---------------------------------------- Please remember to mark the replies as answers if they help and UN-mark them if they provide no help,Vote if they gives you information.

    Wednesday, August 13, 2014 10:34 AM