none
Access folder and file from previous SQL Server installation

    Question

  • Hi to all,

    Unfortunately, a few days the motherboard of my PC stopped working.
    I removed the hard drive from PC and have reassembled it in a USB external box.
    I can access the SQL Server installation folder but i do not see, unfortunately, the directory of instances of SQL Server previously installed.
    The need is to recover .mdf file and some backups stored in the default standard directory (Data, Backup).
    I tried to change the permissions and to assign me as a new owner, but unfortunately nothing has changed.
    Can anyone help me?

    Thanks in advance,
    Giuseppe
    Thursday, February 16, 2017 2:29 PM

All replies

  • Hi

    Have you tried to search for *.mdf?

    Default path/file location

    https://msdn.microsoft.com/en-us/library/ms143547.aspx?f=255&MSPPError=-2147217396


    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Consulting: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance
    SQL Server Integration Services: Business Intelligence

    Thursday, February 16, 2017 2:36 PM
  • When you navigate to the folder in Windows Explorer it should give you a popup to permanently grant yourself access to the folder.

    Otherwise go to the advanced security settings for the folder and change the owner to yourself, enable inheritance and check the box that says "replace all child object permissions ..."

    David 


    Microsoft Technology Center - Dallas <p></p> <a href="http://blogs.msdn.com/dbrowne">My Blog</a>

    Thursday, February 16, 2017 2:48 PM
  • Hi,

    I tried both to search for files with .mdf extension and to change the owner. Just a few minutes ago i connected the external drive to a PC with Debian S.O.  and i found the files and folders.

    I've probably solved, but i did not quite clear why Windows 10 did not allow me the display of this information.

    Thank you very much for the quick reply.

    Giuseppe

    Thursday, February 16, 2017 2:59 PM
  • Hi Giuseppe,

    I have seen a similar phenomenon before, when I add the disk which contains Windows Operation System to another Windows OS machine, the files in the previous OS C disk will not show.

    This problem can be caused by that the files belongs to the user account on the other OS, you can use Linux to access them may because Linux will not be affected by Windows permission. You can try to use the following steps:

    1. Use Administrator account to login this Operation System.
    2. Right-click on the file/folder and choose Properties.
    3. Select the user from the list and then check the permission.
    4. Click the Advanced button, click Change button after Owner row, change it to the current account.

    If you have any other questions, please let me know.

    Best Regards,
    Teige

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 21, 2017 6:28 AM
    Moderator