none
Microsoft .NET Framework 3.5 has encountered a problem during setup. Setup did not complete correctly. RRS feed

  • General discussion

  • I got that when I try to install visual studio 08 and framework 3.5.

    the log is below. Please help. thanks


    Description:
      Microsoft .NET Framework 3.5 has encountered a problem during setup.  Setup did not complete correctly.

    Problem signature:
      Problem Event Name:    VisualStudio8Setup
      Problem Signature 01:    14001
      Problem Signature 02:    3.5.21022.08_ORCAS_X86_NET
      Problem Signature 03:    CBS
      Problem Signature 04:    INST
      Problem Signature 05:    F
      Problem Signature 06:    gencomp750,{61040379-156d-4ece-b126-ea395a3b2
      Problem Signature 07:    BASERET_UNKNOWN
      Problem Signature 08:    -
      Problem Signature 09:    1058
      Problem Signature 10:    WUSA
      OS Version:    6.0.6000.2.0.0.256.1
      Locale ID:    1033

    Additional information about the problem:
      LCID:    1033

    Read our privacy statement:
      http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409
     
    Monday, December 3, 2007 6:10 AM

All replies

  • Sounds like your SxS store is locked. Can you please try the following:

    1)      Check for windows updates and install everything recommended

    2)      Reboot the machine

    3)      Run 3.5 setup again

     

    Tuesday, December 4, 2007 11:28 PM
    Moderator
  • We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions. 

    Thank you!
    Friday, December 7, 2007 3:09 AM
  •  

    I got the same error message on my Vista64 machine.  I had not gone anywhere near any CTP's or betas with this machine and all my updates that windows update said i needed were installed.  I finally tracked it down to a problem the 3.5 runtime installer had installing a dotnet20 hotfix.  An event in the windows setup log had the following error:

     

    Log Name:      Setup
    Source:        Microsoft-Windows-WUSA
    Date:          12/5/2007 1:33:01 PM
    Event ID:      3
    Task Category: None
    Level:         Error
    Keywords:     
    User:          domain\someuser
    Computer:      machine.domain

    Description:
    The Windows update  could not be installed because of an error: 2147948415 "This machine is disabled for file encryption." (Command line: ""C:\Windows\system32\WUSA.exe" "C:\Users\someuser\AppData\Local\Temp\dotnetfx3521022.08\1033\dotnetmsp\x64\NetFX2.0-KB110806-v6000-x64.msu" /quiet /norestart")


     

    It turns out my domain group policy has disabled EFS and I cannot modify this.  I found KB933595 that had a hotfix I could request (free).  After following the installation directions in the article I was able to get the .net 3.5 runtime installed.  According to the KB it looks like Vista32 users would be affected by this as well.

    Friday, December 7, 2007 3:29 PM
  •  

    Hi .

    even i encountered the same problem, i uninstalled framework 3.5 and installed it again from http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en#Instructions and now it works fine

    Friday, January 4, 2008 6:26 AM
  • Wednesday, May 21, 2008 4:53 AM
    Moderator
  • This can be an issue with the permission with the ServiceModel 3.0.0.0 registry key. Find the below link for more details http://codekeep.net/ASPNET/code/snippets/16827/Unable-to-install-NET-Framework-30-35-VS2008-Solution/view.aspx
    Friday, November 6, 2009 5:42 AM
  • This can be an issue with the permission with the ServiceModel 3.0.0.0 registry key. Find the below link for more details

    http://codekeep.net/ASPNET/code/snippets/16827/Unable-to-install-NET-Framework-30-35-VS2008-Solution/view.aspx

    Friday, November 6, 2009 5:51 AM