none
Docker Swarm Overlay DNSSuffix Option Ignored RRS feed

  • Question

  • If I create a network manually with the option com.docker.network.windowsshim.dnssuffix=mydomain.com and run a container connected to it then I can ping anything.mydomain.com.

    When deploying a docker stack configuration with the overlay network and the same driver_opts, the network is created with the proper option but the container instances do not have their dns suffix set and resolution does not work for anything.mydomain.com

    I'm running the latest available patches and I've tried docker version from 17.06 ee-1 to the latest on master.dockerproject.org

    Am I running into an unsupported / unimplemented behavior? I really need to be able to resolve local names as if the container was part of my normal network in order to migrate apps to a container deployment.

    Thursday, August 31, 2017 8:25 PM

All replies

  • As a workaround it seems that the powershell command "Set-DnsClientGlobalSetting -SuffixSearchList mydomain.com" works appropriately within the dockerfile or at runtime if you are using a stack deploy to another network.
    Friday, September 1, 2017 11:41 AM
  • I believe this is expected (but confusing) behavior, as external connectivity via an overlay network isn't really supported (and is really meant only for internal node-to-node communication). It should work, however, with that option attached to the docker_gwbridge network (or other defined  nat/transparent network attached to each node).
    Monday, September 4, 2017 6:00 AM