locked
New Project Created Using VS 2019 Always Uses SSL RRS feed

  • Question

  • User1493428334 posted

    I created a new project with the Visual Studio 2019, using the ASP.NET Web Application template.

    However, when I start any web page in the project, it gives me a message that the project is configured using SSL.

    But I did not configure the project using SSL. I merely started the project from a template mentioned above.

    My question is: What should I do so that the project is not configured using SSL?

    Thanks in advance for your helps,

    Golden

    Sunday, December 29, 2019 5:19 AM

Answers

  • User409696431 posted

    When you create a web project, VS2019 gives you the option to configure it for https, and defaults to having that checked.  You could have unchecked it when you created it.

    For an existing project configured for HTTPS, look at the properties pane for the application and set SSL Enabled from true to false.  At first you may get an error telling you to change the project URL in the web section of the properties page (right-click the web application folder and select properies) from https to http first - do so.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, December 29, 2019 11:48 PM
  • User-719153870 posted

    Hi GoldenMicrosoft,

    GoldenMicrosoft

    From the screen shot above, I don't see the "SSL Enabled" you mentioned. I visited all the items on the left panel. Please tell me where I may have overlooked.

    You can find the "SSL Enabled" @KathyW mentioned in the "Properties Window". Left click your project in "Solution Explorer" and you will see the "Project Window" opened automatically just under the "Solution Explorer".

    If you can not see this property window, please open it in "View" - "Propertie Window" or just press F4.

    Hope this helps.

    Best Regard,

    Yang Shen

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, January 1, 2020 6:48 AM

All replies

  • User409696431 posted

    When you create a web project, VS2019 gives you the option to configure it for https, and defaults to having that checked.  You could have unchecked it when you created it.

    For an existing project configured for HTTPS, look at the properties pane for the application and set SSL Enabled from true to false.  At first you may get an error telling you to change the project URL in the web section of the properties page (right-click the web application folder and select properies) from https to http first - do so.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, December 29, 2019 11:48 PM
  • User1493428334 posted

    Hi Kathy,

    Thank you very much for your reply. Sorry for replying late because first I thought nobody would have replied that soon during this time of the year and secondly because I kept trying to incorporate a screen shot in my reply but the "insert/edit image" of the Forum functionality did not work for me.

    Therefore I provide a link below for my screen shot:
    Click to See Properties Pane Screen Shot

    From the screen shot above, I don't see the "SSL Enabled" you mentioned. I visited all the items on the left panel. Please tell me where I may have overlooked.

    Thanks again,

    Golden

    Wednesday, January 1, 2020 2:27 AM
  • User-719153870 posted

    Hi GoldenMicrosoft,

    GoldenMicrosoft

    From the screen shot above, I don't see the "SSL Enabled" you mentioned. I visited all the items on the left panel. Please tell me where I may have overlooked.

    You can find the "SSL Enabled" @KathyW mentioned in the "Properties Window". Left click your project in "Solution Explorer" and you will see the "Project Window" opened automatically just under the "Solution Explorer".

    If you can not see this property window, please open it in "View" - "Propertie Window" or just press F4.

    Hope this helps.

    Best Regard,

    Yang Shen

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, January 1, 2020 6:48 AM
  • User1493428334 posted

    Hi Yang Shen,

    Many thanks for your response. 

    What I did was right-click on the project then select "Properties". What you did was left-click on the project then go to "Properties". All along I thought they were the same, apparently they are not.

    I did what you suggested, ie, changing "SSL Enabled" from "True" to "False", however,  I got the following error:
    "You can't remove SSL from this site because this Web project is currently configured to browse with this URL. You need to use the Web property page to change the project URL to the non-secure URL first.".

    So I right-clicked on the project and selected "Properties", then I left-clicked "Web" on the left panel, a page came up., on "Project Url" of that page, I changed "https" to "http" and saved it. Then I re-did what you suggested, then it worked.

     I would like to ask you two more questions:
    (1) How do I remove my existing SSL certificates properly, ie, without adverse side effect?
    (2) I tried to include an image by clicking the "Insert/edit Image" button then specify its URL (file path). But the image never shows up. How should I do it?

    Thanks again and Best Regards,

    Golden

    Wednesday, January 1, 2020 8:18 PM
  • User475983607 posted

    (1) How do I remove my existing SSL certificates properly, ie, without adverse side effect?

    Open the certificate store and delete the certificate(s). 

    https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-view-certificates-with-the-mmc-snap-in

    It's up to you to know what certificate you can delete without adverse side effects.   

    (2) I tried to include an image by clicking the "Insert/edit Image" button then specify its URL (file path). But the image never shows up. How should I do it?

    Images must be hosted on an external site.

    Wednesday, January 1, 2020 9:40 PM
  • User-719153870 posted

    Hi Golden,

    In addition to @mgebhard's reply, you can check this post https://forums.asp.net/post/6289100.aspx for more information about how to insert image in this forum.

    Best Regard,

    Yang Shen

    Thursday, January 2, 2020 1:22 AM
  • User1493428334 posted

    Hi Yang Shen and Mgebhard,

    (1) A few days ago, when I was still unable to disable the SSL, I let my IIS generate a cerificate.

    Now I like to remove the certificate. It can be accessed thru Control panel's "Manage computer certificates". The problem is that the certificate has only expiration date, no creation date. And the expiration date of 20240924 is quite odd to me. I expect the expiration date to be sometime in December, since it was created in December.

    The expiration date makes me skeptical that the certificate is really the one I created.

    The certificate is issued by localhost to localhost. And it also sits under IIS and is removable thru IIS manager.

    So I like to confirm that the certificate under the IIS is the one got created a few days ago (although the expiration date is in September of a future year - 2024) and is safe to remove.

    (2) In MSDN forum, image can be uploaded, dragged, or dropped from my local computer, which is easier.

    Thanks so much for your great helps, I very much appreciate.

    Golden

    Thursday, January 2, 2020 2:39 AM
  • User-719153870 posted

    Hi Golden,

    So I like to confirm that the certificate under the IIS is the one got created a few days ago (although the expiration date is in September of a future year - 2024) and is safe to remove.

    In IIS, double click the certificate or right click - "View..." will open you the detailed information of this certificate.

    As you can see, there's a "Valid from" date and it's the date when you import this certificate, maybe you can see this as reference of the date you created it.

    Best Regard,

    Yang Shen

    Thursday, January 2, 2020 8:22 AM
  • User1493428334 posted

    Hi Yang Shen,

    I checked it and it is valid from 20190926 to 20240925.

    When I was prompted whether to let IIS create a certificate, to which I chose "yes", it was around 20191228.

    So the certificate sitting under IIS is not the one created a few days ago. The creation date above of 20190926 is the time of my successful Visual Studio 2019's installation. The certificate looks like a part of VS2019's installation.

    Thanks,

    Golden

    Thursday, January 2, 2020 6:35 PM