none
Migrating integration from 2006 to 2006 R2 Oracle adapter problem RRS feed

  • Question

  • We are currently migrating our old integrations from BizTalk 2006 to Biztalk 2006 R2 enviorment. We have one integration using the Oracle(r) Database adapter on the old enviorment, and I cannot seem to find a similar or the same adapter for the R2 enviorment.

    I have installed WCF LOB adapter back, the ODBC pack and Adpater Pack 2.0 on the R2 enviorment. But i still cant find the Oracle(r) Database adapter. Is it so that this adapter no longer exsist? Or am i doing something wrong?

    Monday, August 23, 2010 11:14 AM

Answers

All replies

  • Hi,

    You will have to add the adapter through BizTalk Administration Console. Right click adapters then add. In the dropdown list you should see the installed adapter for Oracle. Select it and give it a name.

    HTH

    Regards,

    Steef-Jan Wiggers - MVP & MCTS BizTalk Server
    blog: http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Monday, August 23, 2010 12:01 PM
    Moderator
  • The problem is that i cannot find it when i try to add it in the BizTalk Administration Console, the option for Oracle(r) Database isnt there.

    Tuesday, August 24, 2010 6:10 AM
  • Hi,

    Installation of WCF LOB SDK SP2 and then Adapter Pack 2.0 should be enough to be able to add the Oracle(R) Adapter. Did you follow the instructions by installation guide?

    HTH

    Regards,

    Steef-Jan Wiggers - MVP & MCTS BizTalk Server
    blog: http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly

     


    BizTalk
    Tuesday, August 24, 2010 7:04 AM
    Moderator
  • This is what i have done.

    I've uninstalled the LOB adapter Pack, and the biztalk adapter pack 2.0. I tried reinstalling them.

    Installing the WCF LOB Adapter SDK SP2 x64
    Installing the BizTalk Adapter Pack 2.0 - x64 and x86
    Checked the machine.config file for the right bindings (both x86 version and x64) all ok!
    Checked that i installed all the components on the ODAC1110720 version (installed the complete "Oracle Data Access Components for Oracle Client  11.1.0.7.20")

    I still cant find the adapter Oracle(r) Database in the BizTalk console when i try to add a new Adapter.

    I only have the following:
    FILE adapter (in use)
    FTP adapter (in use)
    HTTP adapter (in use)
    MLLP adapter (in use)
    MQSeries (in use)
    MSMQ (in use)
    POP3 (in use)
    Schedule (in use)
    SMTP (in use)
    SOAP (in use)
    SQL (in use)
    WCF-BasicHttp (in use)
    WCF-Custom (in use)
    WCF-CustomIsolated (in use)
    WCF-NetMsmq (in use)
    WCF-NetNamedPipe (in use)
    WCF-NetTcp (in use)
    WCF-WSHttp (in use)
    Windows SharePoint Services (in use)

    WCF-SQL (not in use)
    WCF_Siebel (not in use)
    MSMQT (not in use)
    WCF-SAP (not in use)
    WCF-OracleDB (not in use)
    WCF-OracleEBS (not in use)

    I just cant seem to find the Oracle(r) Database.

    Thursday, August 26, 2010 6:05 AM
  • If you are looking for the older (non WCF) Oracle adapter, you need to install BizTalk Adapters For Enterprise Applications. However, the recommendatiaon is to use the WCF based Oracle adapter on BTS 2006 R2 and above.

    Tuesday, August 31, 2010 3:59 AM