none
.net framework wont start installing RRS feed

  • Question

  • http://sdrv.ms/Tjyckw

    Hi i have checked allmost every related topic and can t find a similar one.

    So my problem is instaling .net framework 4.0. 

    Have full instalation and when i run it extracts all the files and then start builing client profile which i left for 30min and didnt move for 1%.

    I tryed the cleaning tools i uninstaled previous versions i tryed diagnostic tools self repair...i am out if idead u are my last hope xD

    this is a recent...first time that it exited the build client profile

    i run on i5-2500 cpu, and amd radeon hd 6850

    oh and at the end of instalion well when it quited it printed outthis hresult 0x80240009 which i can t find anywhere what it means...plz help me

    OS Version = 6.1.7600, Platform 2
    OS Description = Windows 7 - x64 Ultimate Edition 
    CommandLine = C:\68a1cfa92574c2f9b7\\Setup.exe /x86 /x64
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Client Profile Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 9
    Exe (C:\68a1cfa92574c2f9b7\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\68a1cfa92574c2f9b7\Windows6.1-KB958488-v6001-x64.msu) failed with 0x80240009 - (null).
    Exe (C:\68a1cfa92574c2f9b7\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    Exe (C:\68a1cfa92574c2f9b7\Windows6.1-KB958488-v6001-x64.msu) failed with 0x80240009 - (null).
    Exe (C:\68a1cfa92574c2f9b7\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    Exe (C:\68a1cfa92574c2f9b7\Windows6.1-KB958488-v6001-x64.msu) failed with 0x80240009 - (null).
    Exe (C:\68a1cfa92574c2f9b7\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    Exe (C:\68a1cfa92574c2f9b7\Windows6.1-KB958488-v6001-x64.msu) failed with 0x80240009 - (null).
    Final Result: Installation failed with error code: (0x80240009) (Elapsed time: 0 00:06:24).

    http://sdrv.ms/Tjyckw

    • Edited by krosekri Tuesday, November 27, 2012 9:09 PM
    Tuesday, November 27, 2012 1:35 PM

Answers

All replies

  • Errors in the 0x80 series often involve security issues. Please consider the following options:

    1. Create a NEW Administrator account on your system, then try running the full .NET 4.0 install from that new account.

    2. Follow this sequence:

    Follow ALL these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Tuesday, November 27, 2012 1:52 PM
  • I can t reply u the link...because i didnt verify my email ? How do i do that?

    The link is at the top of the previous post...Sorry for the inconvience.

    Thank you.

    • Edited by krosekri Tuesday, November 27, 2012 9:08 PM
    Tuesday, November 27, 2012 9:08 PM
  • Send TWO links to this email:

    p_vandergoes "at" cox dot net

    1. The link to your logs

    2. The link to this thread

    Wednesday, November 28, 2012 1:02 PM
  • The core issue is here:

    "Microsoft Visual C++ 2010 x86 Redistributable Setup Installation failed with error code: (0x80070642), "User cancelled installation. " (Elapsed time: 0 00:00:05)."

    Try downloading and installing the failing component independently:

    http://www.microsoft.com/downloads/dlx/en-us/listdetailsview.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84
    Wednesday, November 28, 2012 6:55 PM
  • I tryed and it said that i already have a newer version instaled.
    Wednesday, November 28, 2012 7:14 PM
  • We need to see the logs. Please collect and provide as previously.


    Did you look in your installed programs list to see if the VC++ 2010 redistributable is there? If so, did you try uninstalling it, then running the installer?
    • Edited by pvdg42 Wednesday, November 28, 2012 10:56 PM
    Wednesday, November 28, 2012 10:54 PM
  • Hi,

    I found the error message here:

    [11/27/2012, 12:13:24] Error 0x80070424: Failed to open the current cluster

    I think you can try the steps as following below:

    - Download dotNetFx40_Full_x86_x64.exe from http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7
    - Launch commandline prompt as administrator
    - cd (change directory) commandline to location of downloaded dotNetFx40_Full_x86_x64.exe
    - Ran the command: dotNetFx40_Full_x86_x64.exe /x
    - Specified a location to extract when prompted
    - cd commandline to location of extracted files
    - Ran the command: RGB9Rast_x86.msi
    - Ran the command: netfx_Core_x86.msi EXTUI=1
    - Ran the command: netfx_Extended_x86.msi EXTUI=1

    More information you can refer to:

    http://blogs.msdn.com/b/varungupta/archive/2010/06/22/troubleshooting-net-framework-4-install-failures.aspx

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, December 6, 2012 8:22 AM
    Moderator