Visual Studio Prof. 2013 hangs forever when creating a project RRS feed

  • Question

  • Hello, I have been experiencing issues with Visual Studio Professional 2013 Update 4 and after searching and attempting 'fixes' found online, I still have not been able to solve my problem.

    Here are the steps I am taking that lead to my issue:

    1) Open VS under admin privilege.

    2) File -> New -> Project

    3)Templates-> Visual C# - > Console Application(though any C# project results in the same issue). Then I hit 'OK'.

    4) A popup occurs(with a green progress bar) stating Visual Studio is creating the project.

    5)Popup never goes away and the project is created. I've waited over an hour multiple times with no success. The only way to stop the action is to force kill visual studio. Sometimes VS will just become unresponsive too.

    When I run Visual Studio in safemode, it works fine. This would lead me to believe there is a problem with extensions. However, this is a clean install with no extensions installed. I need to be out of Safemode to work on certain projects of mine. I've tried devenv resetsettings, re installing the templates, redoing Setup. I've uninstalled completely and reinstalled completely multiple times, as well as done a repair. My computer's performance is not a problem, many gigs free of RAM and CPU usage is barely being used. I have also done virus scan with Microsoft Security Essentials and malware scan with MalwareBytes which both came back as negative.

    I am out of options, what can I do to fix this issue?

    • Edited by fewjative Wednesday, February 4, 2015 4:29 AM currently only C# projects give me issues
    Wednesday, February 4, 2015 4:18 AM


  • Hi fewjative,

    Thank you for posting in the MSDN forum.

    >> A popup occurs (with a green progress bar) stating Visual Studio is creating the project

    Could you share me a screen shot?

    When I run Visual Studio in safemode, it works fine.

    If it worked well in safe mode, I still doubt that it is related to your Environment, please close all third party tools in your windows like anti-virus or others, test it again.

    Please also run the following command line:

    Devenv.exe /ResetAddin.

    Devenv.exe /ResetSkipPkgs.

    devenv.exe /InstallVSTemplates.

    Please also clean the temp files in your windows, create a new project, and test it again.

    If still no help, please collect the detailed log messages:


    To make sure that it is not your VS setup files issue, maybe you could re-download it from the official site, re-install it again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, February 5, 2015 11:12 AM