locked
Cannot start metro apps anymore after linking with live account.

    Question

  • 1. After installing Windows 8 Developer Preview I created a local account.

    2. I started metro apps and everything seems to work quite well. Now I added a new user with a live id (not connected with the local account).

    3. I continued working with the new user that is identified by the live id. Everything was still ok.

    4. I logged off and back in with my local account. I wanted to connect the local user with the live id. This failed with some hex code and I saw that it tried to create the live id user locally. Ok I already had that live id user.

    5. I decided to delete the live id user and after that connect my live id user with the local account. This worked ok. Windows told me to use the live id the next time I log in. So I immediately logged off to continue using my live id.

    When I now try to start any metro app now, the store app always opens. Going to the metro menu and clicking on the same app again shows the splash screen for some time and then the screen turns cyan. One click on the screen and the metro menu appears again. This happens for any metro app. Logging of or rebooting does not help. After that I turned off syncing but the problem still persists.

    Any ideas how to fix this?


    Edit: Just to add further information. I started Visual Studio and created a new JavaScript Metro Style App. I can run and test that app. The new app is added to the metro start menu and I can also start it from there. Existing metro apps like build, socialite, ... still cannot be started.
    • Edited by Lorendin Friday, September 30, 2011 5:46 PM
    Friday, September 30, 2011 5:39 PM

Answers

All replies