locked
How to configure SharePoint Server 2010 to use a database that is hosted on a server that is running SQL Server in an untrusted domain RRS feed

  • Question

  • I am trying to setup a SharePoint 2010 Foundation server to use a SQL 2008 server that is in an untrusted domain.  I can find the article on 2007, but when applying it to 2010 psconfig tells me the passphrase parameter specified with the configdb command is invalid.

    How do I go about setting up a SharePoint 2010 server to use a SQL server in an untrusted domain?
    Thursday, March 4, 2010 9:04 PM

Answers

  • You need to use the same command line string as Steven Haden's Blog for SharePoint 2007, but for SharePoint 2010 you need to insert the additional parameter ' -passphrase %PASSPHRASE% ' right after the configdb command.

    I just figured this out the hard way (trial and error), I could not find any postings or documentation on this at all.

    • Proposed as answer by Cawood Saturday, April 23, 2011 1:38 AM
    • Marked as answer by Margriet Bruggeman Friday, April 20, 2012 1:53 PM
    Friday, April 22, 2011 7:32 PM

All replies

  • Also now tried useing new-SPConfigurationDatabase -DatabaseCredentials (Get-Credential) and entering in credentials it prompts for thinking that would work, but still wont work it keeps telling me Exception of type 'Microsoft.SharePoint.SPException' was thrown At line:1 char:28
    Thursday, March 4, 2010 10:04 PM
  • You need to use the same command line string as Steven Haden's Blog for SharePoint 2007, but for SharePoint 2010 you need to insert the additional parameter ' -passphrase %PASSPHRASE% ' right after the configdb command.

    I just figured this out the hard way (trial and error), I could not find any postings or documentation on this at all.

    • Proposed as answer by Cawood Saturday, April 23, 2011 1:38 AM
    • Marked as answer by Margriet Bruggeman Friday, April 20, 2012 1:53 PM
    Friday, April 22, 2011 7:32 PM
  • Please use maunt  command  for Sp 2010
    Sunday, October 30, 2011 7:15 PM
  • Mark Great post _ yours is the only one that points this out MS dosen't even have it posted in there commands! Now if I can just get the alias working 
    Monday, November 7, 2011 6:04 PM