none
Kinect v2 does not work on windows 10 Pro N RRS feed

  • Question

  • My setup is as follows: 

    Intel core i7 6700k on a MSI bazooka mother board with the B150 chipset running windows 10. (no nvidia or amd graphic card installed)

    I have tested the kinect on an xbox 1 and i works. I have tested the kinect with the kinect for windows adapter on an other computer core i7 4770k with an older chipset and it worked. 

    I have installed the kinect SDK 2.0 and when i connect the device it shows in the device manager as ok.

    When I run kinect studio v2 I get no feed from the kinect and the leds does not light up.

    In the Kinect v2 Configuration Verifier I get an exclamation mark on the USB controller "Unknown USB 3.0 port detected. Your USB Configuration may support Kinect for windows". I also get an exclamation mark on "Verify Kinect Depth and Color Streams" that says "Result: Waiting for frames from Kinect"

    * I have tried uninstall and reinstall the SDK 2.0 and the driver for the kinect which is 2.0.1410.18000.

    * The device is the only device connected to the intel 3.0 USB controller

    * The USB device driver is "Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft) version 10.0.10586.212 (2016-03-28)

    * The Kinect microphone array works for audio recording

    Should the kinect work with the intel b150 chipset and skylake? 
    I'm out of ideas how to proceed getting the kinect to work, are there any updated device drivers for the kinect? It seems like they are since 2014, before windows 10 and before the skylake were released.

    Update: 

    The kinect wont work on N-versions of the OS, you will need to install "Media Feature Pack for N and KN versions of Windows 10" KB3099229


    • Edited by peterkl Tuesday, July 26, 2016 9:35 AM
    Saturday, July 23, 2016 9:59 AM

All replies

  • Ok, now I bought a transcend PDU 3-card installed it and connected the kinect to that card. 

    I get exactly the same result as when I connected the kinect to the intel usb controller. 

    What I know:

    *The kinect works in xbox 1 and an other computer

    *The transcend card should work

    Does anyone have any suggestions how to proceed? Is there any way to get something like simular to linux 'dmesg' or 'syslog' in windows? Or how are people running windows suppose to figure out whats wrong with their system?

    I've tried the event viewer, but the logging is minimal and I can't see messages from either the hardware nor the kinect monitor service.

    Monday, July 25, 2016 5:47 PM
  • I'm having a similar problem, my configuration is a ASUS GL55VW, i7 6700HQ, NVidia GTX960m, "Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft) version 10.0.10586.212 (2016-03-28)
    When I run Kinect verifier FPS does not goes above 24.

    Using USB View software I get the following info form the port

    External Hub: USB#VID_045E&PID_02D9#5&350590a7&0&17#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    Hub Power:               Self Power
    Number of Ports:         1
    Power switching:         Individual
    Compound device:         Yes
    Over-current Protection: Individual
    Device Descriptor:
    bcdUSB:             0x0300
    bDeviceClass:         0x09
    bDeviceSubClass:      0x00
    bDeviceProtocol:      0x03
    bMaxPacketSize0:      0x09 (9)
    idVendor:           0x045E (Microsoft Corporation)
    idProduct:          0x02D9
    bcdDevice:          0x0073
    iManufacturer:        0x01
    0x0409: "Microsoft Corporation  "
    iProduct:             0x02
    0x0409: "NuiSensor Adaptor      "
    iSerialNumber:        0x00
    bNumConfigurations:   0x01
    ConnectionStatus: DeviceConnected
    Current Config Value: 0x01
    Device Bus Speed:     High
    Device Address:       0x01
    Open Pipes:              1
    Endpoint Descriptor:
    bEndpointAddress:     0x81  IN
    Transfer Type:   Interrupt
    wMaxPacketSize:     0x0002 (2)
    bInterval:            0x08
    Configuration Descriptor:
    wTotalLength:       0x001F
    bNumInterfaces:       0x01
    bConfigurationValue:  0x01
    iConfiguration:       0x00
    bmAttributes:         0xE0 (Bus Powered Self Powered Remote Wakeup)
    MaxPower:             0x00 (0 Ma)
    Interface Descriptor:
    bInterfaceNumber:     0x00
    bAlternateSetting:    0x00
    bNumEndpoints:        0x01
    bInterfaceClass:      0x09 (Hub)
    bInterfaceSubClass:   0x00
    bInterfaceProtocol:   0x00
    iInterface:           0x00
    Endpoint Descriptor:
    bEndpointAddress:     0x81  IN
    Transfer Type:   Interrupt
    wMaxPacketSize:     0x0002 (2)
    bInterval:            0x08
    Unknown Descriptor:
    bDescriptorType:      0x30
    bLength:              0x06
    06 30 00 00 02 00

    • Edited by p3t3r16 Monday, July 25, 2016 6:17 PM
    Monday, July 25, 2016 6:15 PM
  • The problem was not with the USB 3 controller at all. 

    When contacting the support I was recommended to try on of the SDK sample i visual studio. When I ran the sample I got an error message "MFPLAT.DLL is missing". 

    This was because I run the N-version of Windows 10 Pro, which is missing the Windows Media Foundation.

    If you run the N-version of windows 10, you have to install Media Feature Pack for N and KN versions of Windows 10

    I found two versions of the media features pack, KB3010081 and KB3099229. 

    When searching for windows media features pack you will get the KB3010081, but it didn't work for me, I had to install KB3099229 to get it to work.

    Tuesday, July 26, 2016 9:33 AM