locked
Biztalk Server: Facing problem in fetching data from WMI, if Biztalk server configured using remote database RRS feed

  • Question

  • Hi,

    As a part of my case study, I have written scripts to fetch data of BizTalk Server(Like Orchestrations, MessageBox Databse etc.) from WMI.

    Scripts work fine if BizTalk server is configured using local database.

    If a script is run under local sytem administrator account and BizTalk server is configured using remote database with different domain credentials, script fails to fetch data from WMI.

    Could you please provide a pointer to an issue?

    Thanks in advance.

     

    Thursday, November 17, 2011 10:45 AM

All replies

  • See:

    http://technet.microsoft.com/en-us/library/cc787533(WS.10).aspx


    Randy Aldrich Paulo

    MCTS(BizTalk 2010/2006,WCF NET4.0), MCPD | My Blog

    Thursday, November 17, 2011 10:50 AM
  • Hi,

    I tried workarounds mentioned @http://technet.microsoft.com/en-us/library/cc787533(WS.10).aspx ,still facing the same problem.

    When I used WMIExplorer tool or Windows Management Instrumentation Tester tool to explore WMI data, got an exception.

    Details of an exception:

    BizTalk Server cannot access SQL server.  This could be due to one of the following reasons:
    1. Access permissions have been denied to the current user.  Either log on as a user that has been granted permissions to SQL and try again, or grant the current user permission to access SQL Server.
    2. The SQL Server does not exist or an invalid database name has been specified.  Check the name entered for the SQL Server and database to make sure they are correct as provided during SQL Server installation.
    3. The SQL Server exists, but is not currently running.  Use the Windows Service Control Manager or SQL Enterprise Manager to start SQL Server, and try again.
    4. A SQL database file with the same name as the specified database already exists in the Microsoft SQL Server data folder.

    Internal error from OLEDB provider: "Login failed. The login is from an untrusted domain and cannot be used with Windows authentication."

    When I tried to access instances of  MSBTS_MsgBoxSetting class from MicrosoftBiztalkServer namespace using WMI Explorer, it threw an exception:

    SQL Server exists on remote machine and is running.

    Could you please help and provide a way?

     

    Thanks in advance.

     

    Thursday, November 17, 2011 2:04 PM