none
Not receiving Alerts WSS 3.0 RRS feed

  • Question

  • I am trying to configure alerts in my SharePoint Services 3.0 environment but I am running into an issue with alerts not being received.  Basically, if I configure to receive alerts on any list, I receive the initial subscription email but no emails at all after that.  I have tried setting the alert options up multiple ways, but no combo seems to work.

    I inherited this server and did not perform the setup or install WSS3.0. I am also new to SharePoint so I am not super familiar with the structure yet.

    The install is standalone.  Everything is on one 2008 server.  There is no SQL Install on the server so Im assuming it is using the Windows Internal Database for everything.

    This is what I have done so far:

    * tried stopping and restarting the Outgoing email service through the Central Admin with no success.

    *turned on Verbose logging for all events and checked the ULS logs and I can't seem to find any reference to email alerts in the logs.

    *noticed that in windows services mmc the service: Windows SharePoint Services Administration was not running and is set to manual.  I started this service.

    *ran the Sharepoint Best Practice analyzer and recieved mutiple errors related to SQL:

    Error connecting to SQL Server
    A network-related or instance-specific error occurred while establishing a conne
    ction to SQL Server. The server was not found or was not accessible. Verify that
     the instance name is correct and that SQL Server is configured to allow remote
    connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Serve
    r/Instance Specified)

    Ok, so this doesnt look good, but being that I dont have SQL installed does this mean anything?  Windows Internal Database still use SQL? 

    THe test finished and the html report gave the following error:

    The SharePoint 3.0 Central Administration Web application account and the Windows SharePoint Services Timer Service account must be the same

    After researching this it seems like you get this error with default install? I'm not quite where exactly I am checking these accounts, but I checked Central Admin Web App in IIS and then I checked Timer Service under services.msc.  Am I checking the wrong places?  At least in these to spots they both appear to be set as the same which is Network Service.

    Any help, guidance is appreciated .

     

    Thursday, February 10, 2011 8:44 PM

Answers

All replies

  • First of all the windows internal database is a sql database.  Typically you can find your databases by going onto your sharepoint server and then browse to here:

    C:\WINDOWS\SYSMSI\SSEE\MSSQL.2005\MSSQL\Data   (this is just for reference, you don't not need to perform any actions here)

    You should then see multiple databases, such as wss_content.  To allow the remote connections to these databases see this article here: 

    http://support.microsoft.com/kb/914277

    Now, onto the system account.  You should create a domain user account for this.  You can call it something like "SPAdmin" - you want the password to never expire.  This account also needs to be given local admin rights on the SharePoint server as well as dbcreator and securityadmin rights in the SQL databases.  See this here on proper service account priveleges: 

    http://technet.microsoft.com/en-us/library/cc288210(office.12).aspx

    Now that you have your system account setup go to your central administration > operations > service accounts and select the following:

    • Web Application Pool:  Windows SharePoint Services Application
    • Application Pool:  (Choose the one that your sharepoint site uses, you can check which one by looking in IIS)
    • Configurable:  Enter the system account you have setup here.

    Now go to your Windows SharePoint Services Timer Service and change the account to the same account.  Make sure that the timer is started --- this service is what actually puts out the alerts.

    Let's check one more thing that should be set as default, but it's always good to make sure.  Go back to Central Administration > Operations > Timer Job Definitions.... go to the one for "Immediate Alerts" for your web application.  Make sure that it's Schedule Type is set to "minutes".

    Also here is a decent page regarding the alerts issue with a small handful of reasons / resolutions:  http://umakanthn.blogspot.com/2010/01/immediate-alerts-not-working-on.html

    Friday, February 11, 2011 1:45 AM
  • Click the Windows Start button, type services, open the option, sort thru the services and find the SharePoint 3.0 Central Administration Web application account, right click it and choose properties.  Verify and note the user name, close this box and find the Windows SharePoint Timer Service account.  If it doesn't match then change the timer service account (take note of what it is).  OR use STSADM, in you have multiple servers do the following.

    Verify that the SMTP and dependent roles are installed on the server to allow it to relay email.  Link here 

     


    Kris Wagner, MVP, MCITP, MCTS Twitter @sharepointkris Blog: http://www.sharepointkris.com/blog
    Friday, February 11, 2011 4:24 AM
    Moderator
  • Hi mac1234,

     

    The initial alert is not security trimmed. So irrespective of whether the user has privileges on the list or not, the initial alert will be sent.  If the user is not getting alert for any changes, please check whether the user has Read permission on the list.

     

    Check whether the time on the servers in the farm are consistent.  If not, make their time sync with the domain time server using the Net Time command, check the effect.

     

    Use the site administrator to receive alert, what is the result.

     

    Open a command window, go to the BIN folder and run the following command, please let me know the result:

     

    stsadm -o getproperty -pn alerts-enabled -url http://sitename

     

    stsadm -o getproperty -pn job-immediate-alert -url http://sitename

     

    Open the Central Administration page, click “Operations” -“Timer Job Status”, make sure that the following two jobs are showing “success” and 100%:

     

    Change Log & Immediate Alerts.

     

    For more information about how to troubleshoot e-mail alert in SharePoint, please refer to the following article:

    Troubleshooting Alerts

    http://blogs.technet.com/harikumh/archive/2008/05/25/troubleshooting-alerts.aspx

     

    If you have any questions, please let me know.

     

    Rock Wang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Regards, Rock Wang Microsoft Online Community Support
    Friday, February 11, 2011 4:44 AM
  • C:\WINDOWS\SYSMSI\SSEE\MSSQL.2005\MSSQL\Data   (this is just for reference, you don't not need to perform any actions here)

    You should then see multiple databases, such as wss_content.  To allow the remote connections to these databases see this article here: 

    http://support.microsoft.com/kb/914277

    THanks for the reply.  I cant perform any of the items in that KB as I dont have the Configuration tools or any of the referenced items.  All that is installed on this machine is SQL management studio express.  Maybe I need to install something, but it seems like that article is specific to need SQL 2005/2005 Express.
    Friday, February 11, 2011 7:29 PM
  • There is no Central Administration Web Application service.

    I am using a dedicated SMTP server separate from the SharePoint server.

    thanks

    Friday, February 11, 2011 7:33 PM
  • Ok, so:

    Alerts have started working.  After posting to this forum I continued looking over the server settings and suddenly received several alerts for items that were created earlier.  I checked the ULS log and sure enough the Alert entries were showing up as they should.

    However, I'm not excactly sure what caused them to start working and am in no way convinced I have this solved.  The alerts were received at least an hour if not more after I performed the steps in my initial post which were:

     *stopping - starting SMTP service

    *Starting the Windows SharePoint Services Administration service under windows services

     I noticed the alert emails come in as I was RDC’d into the Sharepoint server.   At the time, I had just checked the windows local administrator account, which had the password set to 'Change at next logon' checked.  I unchecked this and set to never expire. Secondly, I was in the middle of performing the stsadm -getproperty checks that I saw that you posted in another forum.  Maybe running the getproperty command kick started something?

     Now here is what is interesting as to the results of these checks:

     My server has 3 sites for sharepoint in IIS.

    Sharepoint 80

    Sharepoint 444

    Sharepoint Central Admin (port 1234)

     

    We only have one Sharepoint site that everyone in our organization goes to which is http://sharepointservername. We also have a DNS alias’ for the Sharepoint servername.  I can get to SHarepoint 80 , the sharepoint DNS alias and the Central admin without a problem, but if I type in http://sharepointservername:444 I get a 404 not found error.  With this I’m thinking that SharePoint on port 80 should be my main site url and I am left wondering what the heck Sharepoint 444 is for.

     Now, with that said running 'stsadm -o getproperty -pn alerts-enabled -url http://sharepointservername' results in the following message:

     The server administration programs and the Windows SharePoint Services Web appli
    cations on this Web server are not compatible.  Ensure that the administration p
    rogram is the same version as the Web application.

     If I run 'stsadm -o getproperty -pn alerts-enabled -url http://sharepointservername:444' I get the following:

    <Property Exist="Yes" Value="yes" />

    Running 'stsadm -o getproperty -pn alerts-enabled on the http://aliasname and http://sharepointservername:1234 urls also results in: <Property Exist="Yes" Value="yes" />

     Ok so now I’m confused.  Why is this error occuring on my port 80 site but not on this 444 site?  I don’t believe there was another version installed.

    Now here is what is throwing me off even more, following up the alerts-enabled command with the –pn job-immediate-alert command results in the following:

    'stsadm -o getproperty -pn job-immediate-alert url http://sharepointservername’ results in:

     The server administration programs and the Windows SharePoint Services Web appli
    cations on this Web server are not compatible.  Ensure that the administration p
    rogram is the same version as the Web application.

     'stsadm -o getproperty -pn job-immediate-alert url’ on http://sharepointservername:444, http://aliasname and http://sharepointservername:1234 results in:

    <Property Exist="No" />

    Any input appreciated.  I will continue researching.

     

     

    Friday, February 11, 2011 9:16 PM
  • Hi mac1234,

     

    From the following error, it usually means that you typed a wrong URL, please double check your alternate access mapping settings, ensure that the URL listed for the Default Zone is the URL of your site, not the Windows Name of your Site's server.  If it is not, edit it (Click on the linked URL name).

     

    The server administration programs and the Windows SharePoint Services Web applications on this Web server are not compatible.  Ensure that the administration program is the same version as the Web application.

     

    From the following information, it means that you don’t specify a frequency schedule to check alerts that are set to be sent immediately. Please specify a schedule.

     

    'stsadm -o getproperty -pn job-immediate-alert url’ on http://sharepointservername:444, http://aliasname and http://sharepointservername:1234 results in:

    <Property Exist="No" />

     

    For more information about Job-immediate-alerts: Stsadm property, please refer to the following article:

     

    http://technet.microsoft.com/en-us/library/cc287693(office.12).aspx

     

    In addition to that, please refer to the following articles to troubleshoot WSS alerts:

     

    http://social.technet.microsoft.com/Forums/en/sharepointadmin/thread/2ced6b9a-156a-43f8-8c97-7b9db86a271e

     

    http://sharepointalert.info/troubleshooting-sharepoint-alerts/

     

    If anything is unclear, please let me know.

     

    Rock Wang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Regards, Rock Wang Microsoft Online Community Support
    • Proposed as answer by Kris Wagner - MVPModerator Monday, February 14, 2011 5:22 AM
    • Unproposed as answer by mac1234 Monday, February 14, 2011 5:00 PM
    • Marked as answer by mac1234 Monday, February 14, 2011 5:00 PM
    Monday, February 14, 2011 3:28 AM
  • Thanks for the reply Rock.

    "From the following error, it usually means that you typed a wrong URL, please double check your alternate access mapping settings, ensure that the URL listed for the Default Zone is the URL of your site, not the Windows Name of your Site's server.  If it is not, edit it (Click on the linked URL name)."

    That indeed appears to be what was happening.  I checked the alternate access mappings and there is no entry for URL I was trying which was just the servername.  Only URL's that have AAM's respond, with the exception of one AAM that has an https prefix.  The AAM with the https is the external link users use and it is assigned as the default zone to my Sharepoint 80 site.  When I run the command on this AAM I receive a different error:

    The system cannot find the path specified.

    With this I'm pretty sure there is something configured incorrectly with my AAM's. 

     

    "From the following information, it means that you don’t specify a frequency schedule to check alerts that are set to be sent immediately. Please specify a schedule"

    As I stated, something I did resulted in the alerts to start being sent and they appear to be working properly at the moment.  In testing the alerts are being sent every 5 minutes, yet when I run the stsadm -pn job-immediate-alert on my sites I receive <Property Exist="No" />.  The exception to this is with the AAM that has https  that results in the cannot find the path specified error. 

    Looking in my windows event logs I have several Gatherer Errors (ID 2436) and quite a few Topology Errors (ID 8214) that reference the AAM urls.

    I am going to start researching AAM's and make sure that these are good.  I will probably start a new topic on AAM's if needed.

    Monday, February 14, 2011 4:58 PM