locked
BSOD on Boot (USBXHCI.SYS)

    Question

  • Hi,

    I've tried to install the Preview multiple times and via multiple methods, but every time I try to boot for the first time I receive the error: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (USBXHCI.SYS). My laptop is an Asus N61Jv with a USB 3.0 port. From what I could gather, USBXHCI.SYS happens to be a USB 3.0 driver. Anyone know what I am doing wrong?

    Thanks.

    Saturday, September 17, 2011 4:49 AM

All replies

  • Are you able to boot into the system later?  If so do you have a crash dump to look at?  It should be located at c:\windows\memory.dmp.  Look for the '.dmp' extenstion.  This will let us look at what when wrong.  Also, do you have an devices attached to the USB 3.0 port who you booted up?
    Sunday, September 18, 2011 9:25 PM
  • I am able to boot into Windows 7 and view the Windows 8 partition as drive G:, but there is no memory.dmp file in the G:\windows\ folder. Are there any other logs I could submit? I originally had a USB 2.0 hard drive attached to the USB 3.0 port, but I also tried booting with no devices attached, to no avail. I appreciate your help.
    Sunday, September 18, 2011 10:56 PM
  • If I am understanding correctly, it sounds like you are not able to boot inot the windows 8 partition at all.  Correct me if that is the case.  In each of the cases, are you hitting the same system error above (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (USBXHCI.SYS)).  Just want to make sure we are delaing with a single issue.  :)

    I would also lik to collect some information about the USB host controller you have.  From the specs of your machine, it looks as the controller is made by Renesas (it might be labeled as NEC).   SThe firmware revisions of the controller can be read (from Windows 7) by using a utility that comes with the NEC driver.  The utility is named 'Nusb3utl.exe'.  It will report back the firmware and software revisions of the controller. 

    Monday, September 19, 2011 4:46 PM
  • You are correct. I can't boot into Windows 8 at all and I get the same error each time. As for the USB host controller, here is what the utility tells me: Driver version: 1.0.17.0,  Firmware version: 3021.
    Monday, September 19, 2011 5:12 PM
  • Sounds like we will need to disable USB 3.0 (temporarily) to get the crash file.  This will allow Windows 8 to boot successfully and process the internal pagefile and create the dump file needed to analyze what is going on.   To do this, we have one of two options.

    Option 1:  Disable in Bios

    Note:  I do not have your laptop so bear with me on the fact the instructions might not be exact. :)  Please do the following...  From a powered off machine, hit the power button and hit the 'esc' key several times to get to the Bios menu.  You might have the choose 'enter setup'.  Once in the setup utility, choose the 'Advanced' menu and look forthe the 'USB 3.0 controller switch' option.  It should be in xhci mode.  Change it to 'ehci' mode.  This will disable the usb 3.0 controller.  After you retrieve the dump file, you can go back to bios and set it back to 'xhci' mode to get USB 3.0 back.  But don't do that for Win8...  we still neeed to help resolve the issue first. :)

    Option 2:  Disable the USB 3.0 drivers

    This is a little trickier than bios method, but still doable.  From you Windows 7 machine take a look at the following KB article on how to disable a service / driver from booting (http://support.microsoft.com/kb/165748).  From the Windows 7 machine you will loadthe Windows 8 registry hive and disable the following drivers (USBXHCI, UCX01000 and USBHUB3).  Set the 'start' mode to '4' and that will disable.  Reset the value (to what it was) for everything to return to 'normal'.

    Let me know when you are able to retrieve the dump file and I will provide instructions for uploading. 

     


    Monday, September 19, 2011 7:45 PM
  • Option 1 didn't work unfortunately, but I was able to boot into Windows 8 using option 2. I have the dump file now, and a message popped up when Windows booted asking me to upload the file, which I did.
    Monday, September 19, 2011 9:28 PM
  • I am having a delay in getting the share location setup (for you to upload the dump file). Bear with me. :)
    Tuesday, September 20, 2011 5:03 PM
  • Hi BrutaI.  I am ready to receive the dump file you have created.  Can you send an email to usb3fb@microsoft.com.  I will respond to you with details on uploading the file to us.  Thanks agqain for you help in gathering data for us to diagnose this further.
    Wednesday, September 21, 2011 5:58 PM
  • thanks for upoading the dump file.  The dump file points to an issue with the storage driver.  I have forwarded it off to the storage team for investigation.
    Thursday, September 22, 2011 4:40 AM
  • Ok, glad I could help.
    Thursday, September 22, 2011 5:13 AM