locked
VS 2012 won't create a new file RRS feed

  • Question

  • Hi, I've run in to a problem using VS 2012 on my surface pro. I'm using Windows 8.1, if that helps. I am trying to create a new win 32 project, but when I attempt to press "ok" and create the file, it exits the new file window momentarily and then reopens brand new again, with no file created. Any insight into this problem would be greatly appreciated.
    Saturday, March 28, 2015 8:25 PM

Answers

  • Browse to a folder that you have permission to write to.  The default is normally

    Documents : Visual 2012 : Project

    But you can use any folder that you have permission.  Normally when VS is opened for the first time it creates this folder.  The first time you open VS on a computer it takes a long time for VS to open.  During this time registry items are created on the computer and the default folder is created.  You may not have the correct permission for the registry and folder to be created.

    I would check with a windows explorer if the default folder was created.  If not try creating the folder your self.  May be delete the existing folder and try again.


    jdweng

    • Marked as answer by Tina-Shi Tuesday, April 7, 2015 2:19 AM
    Sunday, March 29, 2015 3:42 AM
  • Hi Mackenzie,

    >> I am trying to create a new win 32 project, but when I attempt to press "ok" and create the file, it exits the new file window momentarily and then reopens brand new again, with no file created.

    According to your issue, you mean that when you start the VS2012->FILE->New Project->Visual C++->Select the Win32 project like the following screen shot.

    After you click the Ok button, you could not see the Win 32 project Wizard dialog box is showed from this VS2012 like the following screen shot, am I right?

    If yes, could you please tell me if the issue is occurs in the specified C++ Win32 project or all type projects.

    Based on this issue, to check if this issue is related to the project template issue. I suggest you could try to delete your ItemTemplatesCache, ProjectTemplatesCache folder and then run the the devenv /InstallVSTemplates switch and devenv /Setup switch. Please refer to the following steps:

    Step1: Please open Windows Explorer, and navigate to <Visual Studio Installation Path>\Common7\IDE (by default is <C:\Program Files(x86) \Microsoft Visual Studio 11.0\Common7\IDE>)

    Step2:  Delete the ItemTemplatesCacheProjectTemplatesCache folder; 

    Step3: Open Visual Studio Command Prompt (2012 x64 Cross Tools Command Prompt under Start menu -> All Programs -> Microsoft Visual Studio 2012 -> Visual Studio Tools (run it with Administrator privilege: right-click the program -> Run as administrator); 

    Step4: Run the devenv /InstallVSTemplates switch and the devenv /Setup switch

    https://msdn.microsoft.com/en-us/library/ms241279(v=vs.110).aspx

    https://msdn.microsoft.com/en-us/library/ex6a2fad(v=vs.110).aspx

    If the above suggestion still could not help you, please try to repair or re-install this VS2012 and then check this issue again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Tina-Shi Tuesday, April 7, 2015 2:19 AM
    Monday, March 30, 2015 6:43 AM

All replies

  • Browse to a folder that you have permission to write to.  The default is normally

    Documents : Visual 2012 : Project

    But you can use any folder that you have permission.  Normally when VS is opened for the first time it creates this folder.  The first time you open VS on a computer it takes a long time for VS to open.  During this time registry items are created on the computer and the default folder is created.  You may not have the correct permission for the registry and folder to be created.

    I would check with a windows explorer if the default folder was created.  If not try creating the folder your self.  May be delete the existing folder and try again.


    jdweng

    • Marked as answer by Tina-Shi Tuesday, April 7, 2015 2:19 AM
    Sunday, March 29, 2015 3:42 AM
  • Hi Mackenzie,

    >> I am trying to create a new win 32 project, but when I attempt to press "ok" and create the file, it exits the new file window momentarily and then reopens brand new again, with no file created.

    According to your issue, you mean that when you start the VS2012->FILE->New Project->Visual C++->Select the Win32 project like the following screen shot.

    After you click the Ok button, you could not see the Win 32 project Wizard dialog box is showed from this VS2012 like the following screen shot, am I right?

    If yes, could you please tell me if the issue is occurs in the specified C++ Win32 project or all type projects.

    Based on this issue, to check if this issue is related to the project template issue. I suggest you could try to delete your ItemTemplatesCache, ProjectTemplatesCache folder and then run the the devenv /InstallVSTemplates switch and devenv /Setup switch. Please refer to the following steps:

    Step1: Please open Windows Explorer, and navigate to <Visual Studio Installation Path>\Common7\IDE (by default is <C:\Program Files(x86) \Microsoft Visual Studio 11.0\Common7\IDE>)

    Step2:  Delete the ItemTemplatesCacheProjectTemplatesCache folder; 

    Step3: Open Visual Studio Command Prompt (2012 x64 Cross Tools Command Prompt under Start menu -> All Programs -> Microsoft Visual Studio 2012 -> Visual Studio Tools (run it with Administrator privilege: right-click the program -> Run as administrator); 

    Step4: Run the devenv /InstallVSTemplates switch and the devenv /Setup switch

    https://msdn.microsoft.com/en-us/library/ms241279(v=vs.110).aspx

    https://msdn.microsoft.com/en-us/library/ex6a2fad(v=vs.110).aspx

    If the above suggestion still could not help you, please try to repair or re-install this VS2012 and then check this issue again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Tina-Shi Tuesday, April 7, 2015 2:19 AM
    Monday, March 30, 2015 6:43 AM