locked
New tests not showing up in Test windows. RRS feed

  • Question

  • In VS2010 I have created a test project and have a few test classes that contain my unit tests.  When I add new tests, by any method, and rebuild the test project the new tests do not show up in any of the testing windows until I close and re-open the project.  Does anyone have any idea why this might be happening?
    Thursday, October 21, 2010 6:27 PM

Answers

All replies

  • Hello,

    The behavior in VS 2010 requires tests to be rebuilt before they are discovered in the Test View. I tried the scenario locally and it works. Can you clean out the solution and try again. Please share more details about your setup and/or your test project so we can take a closer look.

     

    Thanks,

    Abhishek [MSFT]

    Friday, November 5, 2010 12:00 PM
  • I agree. I am facing the same problem, the newly added unit tests show up only after closing and re-opening visual studio 2010.

    Regards,

    Sandeep

     

    Monday, November 8, 2010 10:06 AM
  • Hi Sandeep and Bob,

    Bit strange, I have tested this myself and have to agree with Abhishek; after rebuilding the tests appear in the Test list.

    Kind regards,
    Tom de Koning


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".
    Tuesday, November 9, 2010 5:41 AM
  • Unchecking "Disable background discovery of test methods"  helped me in resolving this issue.  I found it here:

    http://stackoverflow.com/questions/2645442/visual-studio-2010-does-not-discover-new-unit-tests

    Thursday, November 11, 2010 8:30 AM