locked
The AVD Manager visual interface is not available for your version of sdk tools 26.1.1. Please use.. RRS feed

  • Question

  • User356677 posted

    When I try to open the Android Emulator Manager in Visual Studio, a message is shown with the error: "The AVD Manager visual interface is not available for your version of sdk tools 26.1.1. Please use the sdk manager to downgrade to sdk tools vs25.x".

    I already used the sdk manager to download sdk tools version 25. However somehow, Visual Studio is still seeing the 26.1.1 version.

    How I workaround this? Considering that I cannot uninstall sdk tools 26.1.1 as it is needed in React Native development?

    Thank you

    Tuesday, March 6, 2018 2:17 PM

Answers

  • User327754 posted

    I also update my Android SDK Tools 25.2.5 to 26.1.1 after updating i faced the same issue like you,

    Now the solution of this issue is Open Android SDK and Tools Manager and click on tools and go to first option Android SDK Tools select Android SDK tools 25.2.5 and click on apply changes. It uninstall 26.1.1 and reinstall lower version.

    Like This.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, March 7, 2018 4:57 PM

All replies

  • User327754 posted

    I also update my Android SDK Tools 25.2.5 to 26.1.1 after updating i faced the same issue like you,

    Now the solution of this issue is Open Android SDK and Tools Manager and click on tools and go to first option Android SDK Tools select Android SDK tools 25.2.5 and click on apply changes. It uninstall 26.1.1 and reinstall lower version.

    Like This.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, March 7, 2018 4:57 PM
  • User12817 posted

    Use our new preview:

    https://developer.xamarin.com/guides/android/getting_started/installation/android-emulator/xamarin-emulator-manager/

    Thursday, March 8, 2018 4:26 AM
  • User124403 posted

    UPDATE: NOW, the better answer is to UPDATE your visual studio to the latest version (to 15.7 or higher), which includes the xamarin emulator manager mentioned by JonDouglas.

    After doing so, might need to update Android SDK and Tools, if they are not already at current versions.

    Thursday, June 28, 2018 11:05 PM