none
The Messaging Engine failed to register the adapter for "WCF-BasicHttp" for the receive location

    Question

  • Could anyone please help in resolving the following error:

    Server Error in '/BizTalkXXXMyAppWcfService' Application.

    --------------------------------------------------------------------------------

    The Messaging Engine failed to register the adapter for "WCF-BasicHttp" for the receive location "/BizTalkXXXMyAppWcfService/XXXMyApp.svc".

    1.        Please verify that the receive location exists.

    It does exist: When I go to All Artifacts >> Receive Locations I can see: WcfService_BizTalkXXXMyAppWcfService/XXXMyApp

    Also it is Enabled, green, up and running.

    1.         …and that the isolated adapter runs under an account that has access to the BizTalk databases. – Checked, the BizTalkUser has all the permissions to access BizTalk databases.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Runtime.InteropServices.COMException: The Messaging Engine failed to register the adapter for "WCF-BasicHttp" for the receive location "/BizTalkXXXMyAppWcfService/XXXMyApp.svc". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

    Stack Trace:

    [COMException (0xc0c01666): The Messaging Engine failed to register the adapter for "WCF-BasicHttp" for the receive location "/BizTalkXXXMyAppWcfService/XXXMyApp.svc". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases. ]

       Microsoft.BizTalk.TransportProxy.Interop.IBTTransportProxy.RegisterIsolatedReceiver(String url, IBTTransportConfig callback) +0

       Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfIsolatedReceiver`2.RegisterIsolatedReceiver(Uri uri) +318

    [AdapterException: Failed to register isolated receiver for address "/BizTalkXXXMyAppWcfService/XXXMyApp.svc"; receive location does not exist or is disabled.]

       Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfIsolatedReceiver`2.RegisterIsolatedReceiver(Uri uri) +875

       Microsoft.BizTalk.Adapter.Wcf.Runtime.WebServiceHostFactory`3.CreateServiceHost(String constructorString, Uri[] baseAddresses) +363

       System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath) +1423

       System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +50

       System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +1132

    [ServiceActivationException: The service '/BizTalkXXXMyAppWcfService/XXXMyApp.svc' cannot be activated due to an exception during compilation.  The exception message is: Failed to register isolated receiver for address "/BizTalkXXXMyAppWcfService/XXXMyApp.svc"; receive location does not exist or is disabled..]

       System.Runtime.AsyncResult.End(IAsyncResult result) +890624

       System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +180062

       System.Web.AsyncEventExecutionStep.OnAsyncEventCompletion(IAsyncResult ar) +107

    Thursday, March 14, 2013 2:56 PM

Answers

  • Hi,

    This seems  to be a permission issue.

    Makesure account used in the application pool is a member of the BizTalk Isolated Host Users group.

    Also its working considering either make the ASPNET user account a member of your BizTalk Isolated Host Users group to make sure it has access to the biztalk databases (or change the asp.net services to run under a different account, which would need to be done from the framework's core .config files)

    Regards


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    Thursday, March 14, 2013 3:16 PM
  • Actually it was missing isolated host. It's good idea to check to which host is the receive location connected.

    The system is up and running, after adding the proper isolated host and redeploying the application in BT.

    Thursday, March 14, 2013 4:10 PM

All replies

  • Also when I go to IIS BizTalkXXXMyAppWcfService > Basic Settings > Test Connections - I get two green icons in the Results, both for Pass-through and "Path is accessible..."
    Thursday, March 14, 2013 3:01 PM
  • Hi,

    This seems  to be a permission issue.

    Makesure account used in the application pool is a member of the BizTalk Isolated Host Users group.

    Also its working considering either make the ASPNET user account a member of your BizTalk Isolated Host Users group to make sure it has access to the biztalk databases (or change the asp.net services to run under a different account, which would need to be done from the framework's core .config files)

    Regards


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    Thursday, March 14, 2013 3:16 PM
  • Actually it was missing isolated host. It's good idea to check to which host is the receive location connected.

    The system is up and running, after adding the proper isolated host and redeploying the application in BT.

    Thursday, March 14, 2013 4:10 PM
  • Glad its working.

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    Thursday, March 14, 2013 4:19 PM
  • Hi,

    another thing tocheck, for me it was to add a receive handler for the isolated host name.

    Regards

    Thursday, May 15, 2014 12:52 PM
  • I faced similar issue...

    I have multiple applications in BizTalk which have receive locations using the SOAP adapter. Each of the application has its own Application Pool Configured in IIS .All the Receive locations had the default Receive Handler (BizTalkServerIsolatedHost).Recently a new application with receive location using the WCF-WebHttp adapter was added. I Ran into the issue with the below error, and all the older application stopped working.

    Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases 

    To Resolve this, I created a new Isolated Host and used this Receive Handler for the WCF-WebHttp Receive Location.  It Worked Fine!!

    The issue is seen again after some other deployment, and restarting the host Instances and application pools just , dint work. Disabling and enabling all the Receive Locations resolved this.

    It worked, but is there still a way that this can be controlled ? Any checks or settings that can prevent this issue!!

    Wednesday, January 4, 2017 11:20 PM
  • Hello,

    Please check with the Application pool under which the service is running so the application pool which is in the IIS has the access and running in one of users who has the required permission.


    Nagaraja Karur

    Wednesday, March 7, 2018 9:52 AM