none
Framework 4 windows 7 doesn't want to install RRS feed

  • Question

  • Hello,

    I tried everything. Framework 4 does not want to install. Each time i try it stays stuck in the installation process. I removed it with an removal tool.. an reinstalled it... didn't work. I tried to repair it... didn't work. I need Framework 4 for some programs and games. Games that I played before on this computer. What can I do? Because it stays stuck in the installation process I dont get a error report or something.. The set up verifier tells me that I also have framework 2.0/3.0 and 3.5. I don't see them in programs and features. I thought I removed them all with the removal tool.. Can you help me?

    Sunday, November 13, 2011 10:52 AM

Answers

  • Windows 7 installs .NET Framework 2.0/3.0/3.5 through 3.5 SP1 as an *integral* part of the OS. Therefore, you will not see them in your installed programs list. Further, you *cannot* remove them unless you resort to destructive techniques such as manually removing files, folders and registry entries. If you have done any of those things, you will have to reinstall Windows 7.

    .NET Framework 4.0 is completely *independent* of the integral frameworks and the embedded frameworks have *nothing* to do with your .NET Framework 4.0 installation issues.

    To assess your issues, please do the following:

    1. Download the .NET Framework 4.0 standalone installer:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the standalone installer, clear out your %temp% directory and disable your AV software.

    3. Run the installer As Administrator.

    4. If the install fails, collect and share your install logs as follows:

    Please collect your install logs logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    The logs will show us what is going on in your system.


    Sunday, November 13, 2011 7:45 PM