locked
404 for HTTPS url RRS feed

  • Question

  • I enabled HTTPS for an azure CDN - however I'm getting a 404 for (any) access to the HTTPS url. Does it take a while to propagate even when just enabling HTTPS, or is something else going on?
    Friday, May 1, 2015 5:27 PM

Answers

  • Hi Eddyfice,

    It may take up to 60 minutes because the settings you’ve just applied may take that long to propagate to all CDN edge locations, globally.

    Regards,

    Manu

    Tuesday, May 5, 2015 1:45 PM

All replies

  • To enable https on Azure VM you need 2 steps.

    First is opening port 443 on VM firewall.

    Second is editing Azure service endpoint to direct https from public port 433 to private port 433 port.

    http://azure.microsoft.com/en-us/documentation/articles/virtual-machines-set-up-endpoints/

    As I use port https for almost all my VMs in Azure, I can tell you from expirience that for me it always works inside few seconds.


    Mustafa Toroman

    • Proposed as answer by rnihad Monday, May 4, 2015 7:41 AM
    Friday, May 1, 2015 10:48 PM
  • Hi Eddyfice,

    It may take up to 60 minutes because the settings you’ve just applied may take that long to propagate to all CDN edge locations, globally.

    Regards,

    Manu

    Tuesday, May 5, 2015 1:45 PM