none
issue while importing the MSI during Biztalk Deployment to Remote Machine RRS feed

  • Question

  • The batch move the Setup.bat script and MSI into Devserver location and try to execute the setup.bat (to import the Msi into BizTalk Management Database)Using Psexec .I am getting the following Error

    C:\Documents and Settings\rsingh\Desktop\RemoteDeploy>xcopy "C:\Documents and Se
    
    ttings\rsingh\Desktop\RemoteDeploy\test" "\\devSvr\Users\rsingh\Desktop\DEVFo
    
    lder"
    
    C:\Documents and Settings\rsingh\Desktop\RemoteDeploy\test\DEVsetup.bat
    
    C:\Documents and Settings\rsingh\Desktop\RemoteDeploy\test\helloworld.msi
    
    2 File(s) copied
    
    
    
    
    
    C:\Documents and Settings\rsingh\Desktop\RemoteDeploy>psexec "\\devsvr" -u usrname -p pwd 
    
    cmd.exe /c "\\devserver\Users\rsingh\Desktop\DEVFolder"\DEV
    
    setup.bat
    
    
    
    C:\Windows\system32>BTSTask ImportApp /Package:"\\devsvr\Users\rsingh\Desktop
    
    \DEVFolder\helloworld.msi" /ApplicationName:helloworld /Overwrite /server=devsqlsvr /Database=BizTalkMgmtDb
    
    Microsoft (R) BizTalk Application Deployment Utility Version 3.8.368.0
    
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.
    
    
    
    Information: Importing package "\\devserver\Users\rsingh\Desktop\DEVFolder\hello
    
    world.msi" into application "helloworld" in BizTalk configuration database (serv
    
    er="devsqlsvr", database="BizTalkMgmtDb")...
    
    Error: A database failure occurred due to database connectivity problems.
    
    
    
    
    
    Command failed with 1 errors, 0 warnings.


    If the try to import the Msi into Biztalk Management Database of my devserver from Local Machine   using Command line Arguments
    I am getting following Error

     

    Error: Cannot open database BizTalkMgmtDb on server Devsqlsvr.Ve
    
    rify that you have the required security permissions and that communication betw
    
    een Distributed Transaction Coordinator services on the machines involved is not
    
     prevented by current DTC security,   firewall or authentication settings.
    
    Exception of type 'System.EnterpriseServices.TransactionProxyException' was thro
    
    wn.
    
    Network access for Distributed Transaction Manager (MSDTC) has been disabled. Pl
    
    ease enable DTC for network access in the security configuration for MSDTC using
    
     the Component Services Administrative tool.
    
    The transaction manager has disabled its support for remote/network transactions
    
    . (Exception from HRESULT: 0x8004D024)
    
    
    
    
    
    Command failed with 1 errors, 0 warnings.
    
    
    
    


    Any thought on this

     

    Friday, January 15, 2010 10:51 PM

Answers

All replies

  • Like the error says, open the dcomcnfg.exe, expand till you see the MS DTC settings, right-click on Local and go to Properties and then check the network access box. Then a restart is usually good to completely refresh MSDTC.

    This needs to be set on the SQL and BizTalk servers.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Saturday, January 16, 2010 3:22 AM
    Moderator
  • There may be othe rissues with MSDTC.

    For the most common issues (in my experience) see http://blog.eliasen.dk/2008/11/10/TransactionsGivingYouAHeadache.aspx

    eliasen, representing himself and not the company he works for.
    Three times MVP and three times MCTS in BizTalk.
    Blog: http://blog.eliasen.dk
    Sunday, January 17, 2010 11:02 PM
  • Hi,

    I'm getting this exact error that rksingh described.  My issue doesn't appear to be with DTC.  I ran the DTCTester and everything works.  I have the steps to uninstall and install the BizTalk application in a PowerShell script.  If I run it locally, everything succeeds.  If I run it remotely with PSExec, it fails.  I am able to access the database fine because other commands are workings.  It is only failing on the BTSTask ImportApp and RemoveApp commands.  I also tried to use the PSBizTalk Provider (http://psbiztalk.codeplex.com/), however I also get the following error: "Unable to commit changes to the BizTalk management database"

    I would appreciate any help.

    Thanks,

    Mike


    blog - http://www.codesmartnothard.com
    Tuesday, December 21, 2010 7:56 PM
  • I was finally able to get this working with PSExec.  I had to use the -e option to have it not load the user environment.  This doesn't seem intuitive that this would have resolved it.  Now both the BTSTask ImportApp and RemoveApp are working fine.   Also the PSBizTalk cmdlets work with this too.

    I hope this helps,

    Mike


    blog - http://www.codesmartnothard.com
    • Proposed as answer by MikeDouglasMVP Thursday, December 23, 2010 4:05 PM
    Thursday, December 23, 2010 4:04 PM