none
Error in Application Event Log when upload document to document library RRS feed

  • Question

  • Hi All,

    Could you please help with any information about what mean error that i received in event log each time a user upload document in document library on project workspace(site).

    Log Name:      Application
    Source:        Microsoft-SharePoint Products-SharePoint Foundation
    Date:          16.02.2011 17:51:48
    Event ID:      6875
    Task Category: General
    Level:         Error
    Keywords:     
    User:          domain\user
    Computer:     
    Description:
    Error loading and running event receiver Microsoft.Office.Project.PWA.WSSEventReceivers.PSDBUpdater in Microsoft.Office.Project.Server.PWA,Version=14.0.0.0,Culture=neutral,PublicKeyToken=71e9bce111e9429c. Additional information is below.

    : Value cannot be null.
    Parameter name: s

    Error occured only when user connected to internal project site from Internet and collected on our WebFrontEnd Server.

     

     

    Wednesday, February 16, 2011 4:08 PM

All replies

  • Does anyone have a solution to this? I just verified that I (and my users, of which there are many) cause the same error in the App / ULS logs when uploading any file to any PWA site document library. We have a lot of file uploads and changes so my App logs are littered with these 6875 errors.

    I have Project Server 2010 with SP1, Windows Server 2008 SP2.

    Thursday, September 8, 2011 7:16 PM
  • Hi,

    Have you enabled the SharePoint workflow in the site collection?

    Please review this topic http://social.technet.microsoft.com/Forums/en-US/projectserver2010general/thread/2fdbb8d3-5073-4140-b9f4-e2f646fd4a3a/ and see if it also fixes your problem (use a different account).

    I hope this helps,
    Hans


    My EPM blog: Projectopolis
    Thursday, September 8, 2011 7:33 PM
    Moderator
  • Im looking for solution of this problem too.
    When user upload any file to any PWA site document library cause error in App/ULS logs (in ULS no messages about error in workflow).
    Description:
    Error loading and running event receiver Microsoft.Office.Project.PWA.WSSEventReceivers.PSDBUpdater in Microsoft.Office.Project.Server.PWA,Version=14.0.0.0,Culture=neutral,PublicKeyToken=71e9bce111e9429c. Additional information is below.
    : Value cannot be null.
    Parameter name: s
    Tuesday, October 18, 2011 8:57 AM
  • Having the same issue.
    Friday, December 2, 2011 2:47 PM
  • This event-handler only appears on the "Project Documents" document library in Workspace sites.  Its purpose is to update the Project Server database with the linked issues/risks/tasks that can be linked to the document through it's properties page.

    To my knowledge this event handler needs at least three things to function properly:

    1. The Web Property "PWAURL" contains the PWA Url to contact the PWA instance that the web belongs to.  This can be broken when you move a Workspace web from one environment to another.
    2. The Web Property "MSPWAPROJUID" contains the ProjectUID so that the handler knows which project its in. This is almost never broken.
    3. The Handler is made available to the document library via the hidden feature "PWSDocLibs" GUID: 525dc00c-0745-47c0-8073-221c2ec22f0f. This feature is enabled by default in the Project Workspace Template, but for some reason it could have been deactivated in yours.  Maybe good idea to check this via PowerShell.

    I would check these three things to make sure the server-side configuration is correct.

    Regards,

       James.

     


    James Boman - http://www.boman.biz Software Consultant for IPMO - http://www.ipmo.com.au
    Tuesday, December 20, 2011 11:52 PM
  • Error occured only when user connected to internal project site from Internet and collected on our WebFrontEnd Server.

     

     


    So are you saying that this only occurs for Internet users, and not for people on the Internal network?

    Perhaps these users are coming in via a different zone - using a different Authentication Provider?  Perhaps this is a Kerberos problem?

    J.


    James Boman - http://www.boman.biz Software Consultant for IPMO - http://www.ipmo.com.au
    Wednesday, December 21, 2011 12:30 AM
  • Anyone found a solution? I'm having the same problem.

    I am using an internal network only. But in different domains.

     

    Friday, January 6, 2012 12:33 PM
  • James Boman thank you. I try to deactivate "PWSDocLibs" feature via PowerShell - Disable-SPFeature PWSDocLibs -Url http://test/PWA/test_project/ but error still exists, even after enable this feature.
    Monday, January 16, 2012 7:36 AM
  • HI ,

    Have you guys checked your ULS logs ? There should be more detailed error info in there ? If you have kindly post the errors here, as i agree with James that it could be an authentication issue.

    Do you perhaps use Forms Authentication ?

    Andre


    http://av-epm.blogspot.com
    Wednesday, January 18, 2012 11:16 AM
  • The ULS logs on my server show the same error that is in the event logs. Each instance seems to have this corresponding alert that happens at the same time.

    An SPRequest object was not disposed before the end of this thread.  To avoid wasting system resources, dispose of this object or its parent (such as an SPSite or SPWeb) as soon as you are done using it.  This object will now be disposed.  Allocation Id: {61F0D7D1-178A-404C-BCD1-CAFD62B43D8B}  To determine where this object was allocated, set Microsoft.SharePoint.Administration.SPWebService.ContentService.CollectSPRequestAllocationCallStacks = true.

    Thanks

    Wednesday, January 18, 2012 1:49 PM
  • Hi.

    Reflector shows the most likely place where this exact error message may originate from: the UpdatePSDB() method that loads XML from the "Links" property of the item processed and gets linked items. 

    Therefore, troubleshooting should include inspection of the "Links" property of the documents in Project Documents library.

    str = this._item["Links"] as string;
    

    ...

    string s = documentElement.SelectSingleNode("NewXML").InnerXml;

    ...

    ds.LinkedItems.ReadXml(new StringReader(s));
    

    • Proposed as answer by AKrasheninnikov Thursday, November 8, 2012 10:56 AM
    Thursday, November 8, 2012 10:17 AM