none
Wrong namespace Error for SAP IDOC comes still after namespace fixed RRS feed

  • Question

  • Hi Pros,

    I am facing a problem with my SAP->BizTalk connection.

    The errormessage we get clearifys the initial Problem, SAP tries to send an IDOC to BizTalk of which BizTalk has no schema definition. Wrong Namespace.

    "There was a failure executing the receive pipeline: "Microsoft.BizTalk.DefaultPipelines.XMLReceive, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "XML disassembler" Receive Port: "RP.MyPort" URI: "sap://CLIENT=100;LANG=DE;@d/MySAP?ListenerDest=MyDestination&RfcSdkTrace=False&AbapDebug=False" Reason: Finding the document specification by message type "http://Microsoft.LobServices.Sap/2007/03/Idoc/3/_x002F_VFE_x002F_V2032_SALESORDERDATAPOR01//740/Receive#Receive" failed. Verify the schema deployed properly."

    So we fixed that in SAP and the new IDOCs come with the correct namespace. However the error message appears every 3 hours in the eventlog of BizTalk Server. As if the message with the wrong namespace got stuck somewhere and the SAP Adapter trys again and again to send it to BizTalk.

    We already did delete all faulty messages in SAP in Transaction WE02 so where is this message coming from?

    Any Idears where to search or what to restart?

    Friday, September 7, 2018 8:55 AM

All replies

  • There has to be some process on SAP side that is sending the old version to BizTalk. The tricky bit is to work out with your BASIS admins what is causing this.

    Thanks Arindam

    Monday, September 10, 2018 5:05 AM
    Moderator