none
Event id-1310, Source- ASP.NET 2.0.50727.0 RRS feed

Answers

  • Hi Bhaskarpattnaik,

    Thank you for posting in MSDN forum.

    This forum is discuss Visual Studio Setup and installation.                        

    I did a research and found a blog the same error message as yours, you may refer to here:

    http://forums.asp.net/t/1996296.aspx?event+id+1310+event+code+3006+ASP+NET+2+0+50727+0          

    Method#1 Go to the properties of precompiled dll’s, check to see if it has following security message (at the bottom of the window): "This file came from another computer and might be blocked to help protect this computer." If present, click "Unblock", "Apply" and "OK".

    If you have multiple dlls in your application, you would need to perform this step to all dlls one by one.

    Method#2 Run the below caspol command to resolve the issue Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -ag 1 -url "file:////c:\mysitecontent\*" FullTrust -exclusive on

    Note: Please substitute "c:\mysitecontent\*" with actual path where ASP.net pre compiled dlls are located.

    Alternatively, you can use below methods to get around the issue.

    To avoid the "This file came from another computer and might be blocked to help protect this computer." You can use one of the following methods depending on your scenario.

    1) Move all the files to non NTFS partition i.e. FAT and move them back to NTFS partition. When you move the files to non NTFS partition, it will not maintain zone information.

    2) Use the "Strems v 1.56" tool to remove streams

    a. Download "Streams v1.56" from http://technet.microsoft.com/en-us/sysinternals/bb897440.aspx

    b. Execute the following command from command line:

    "streams -s -d directory"

    3) If you have copied a zip file to your machine that has the above attribute, before you extract, just unblock the zip file( as mentioned in resolution section) and then proceed with extraction.

    4) There is a Group Policy, that you can Enable to make sure zone information is not preserved.

    a. Run gpedit.msc ( From Run Prompt or CMD prompt)

    b. Navigate to Local Security Policy ==> User Configuration ==> Administrative Templates ==>Windows Components ==>Attachment Manager

    c. Enable "Do not preserve zone information in file attachments" setting.

    This will only make sure that zone information is not present for the files that you copy after the policy is enabled. For Existing files, you would still need to use one of the above methods. Also, please consult with your Administrator, Team before you enable this setting, as this might be needed for other applications and might break those, if you enable it without taking consent from Administrator(s)/your team.

    Please refer to:http://blogs.msdn.com/b/narahari/archive/2010/06/03/system-security-securityexception-request-for-the-permission-of-type-system-web-aspnethostingpermission-system-version-2-0-0-0-culture-neutral-publickeytoken-b77a5c561934e089-failed.aspx

    Besides, as your issue is related to ASP.NET, if you have further question, I recommend you go toASP.netforum for dedicated support.

    Thank you for your understanding.

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, December 9, 2015 2:10 AM
    Moderator