"PSAPI.DLL" error - whilst trying to install Oracle 10G RC2


  • Morning All,

    Whilst trying to install Oracle 10G RC2 onto my WES build I get the following "javaw.exe Entry Point Not Found"error message "The procedure entry point GetProcessImageFileNameW could not be located in the dynamic link library PSAPI.DLL".

    I have checked by WES image and the dll is located in "C:\Windows\System32".

    I have no idea what to do about this.

    As ever any help greatly appreciated.

    - Doug
    Tuesday, January 19, 2010 10:30 AM

All replies

  • You might want to run a monitoring tool such as InCtr5 or AShampoo to monitor what files and reg keys get added to an XP Pro system when you install this application.  Analyzing the files with Dependency Walker will show what OS files the app depends on , so you can determine if the OS features that the app needs are present on the Std09 image or if they need to be added and the image rebuilt.

    See more info on componentizing applications in the App & Componentization sections of the Standard 2009 Learn page (
    Friday, January 22, 2010 9:09 PM
  • I have the same issue.  I found that if I'm quick about it I can browse to the temp folder where oracle unpacks its setup files and overwrite PSAPI.DLL with version 5.1.2600.5512 and I do not get this error.  attempting to automate this solution is problematic because oracle appends the current date and time to the temp folder so it's never in the the same location from one install to the next.  I tried all kinds of other tricks like attempting to control which version of PSAPI.DLL oracle setup uses by changing the PATH environment variable but it doesn't seem to help.  Were you able to find a more elegant solution?

    Tuesday, March 09, 2010 8:47 PM
  • It's true darece01. In the folder C:\Users\user_name\AppData\Local\Temp\ the oracle installer creates a folder for each installation launched. We launched the installer, and when it shows the list of products to be installed waiting for our confirmation to proceed, the installer unzipped his own psapi.dll in the root folder. At that moment would have to change (rename the existing and copy the new ) psapi.dll file. But the versions of the dll I've tried also fail, version 5.1.2600 of which you speak I could not find.

    There is other solution to installer oracle client in Windows 7. Download installer version 10203_vista_w2k8_x86_production_client. It detected the OS as wrong version, but we can check for the installer to ignore this problem. I can't use the protocol for ODBC, hovewer I can connect to the database management software BD.

    Sorry for my English



    [Spanish] Lo que dices es cierto darece01. En la carpeta C:\Users\user_name\AppData\Local\Temp\ el instalador crea una carpeta cada vez que se lanza el instalador. Cuando nosotros lanzamos el instalador, cuando se nos muestra la lista de productos que va a instalar y está esperando nuestra confirmación para continuar, el instalador ha descomprimido su propio psapi.dll en el raíz de la carpeta que crea. En ese momento se podría dar cambiazo (renombrar el existente y copiar el nuevo). Yo no he conseguido ponerle una versión que funcione, aunque no he podido encontrar la versión 5.1.2600 de la que habla darece01.

    Otra solución para poder isntalar el cliente en W7 es descargar el instalador 10203_vista_w2k8_x86_production_client Este detecta que el SO es incorrecto, pero podemos indicarle con un check que ignore el problema. Después de la instalación no puedo utilizar el protocolo de oracle en los ODBC, al menos si puedo utilizar la instalación para conectar a la BD con programas de administración de BD.

    Friday, March 25, 2011 9:26 AM
  • yeah nice one Darce, if you run the installer, then stop at feature selection, its created the temp install folder with date /time etc, if you copy the systems PSAPI.dll into that folder, and set as readonly (haven't checked if this is actually required, installer may not expand the old one over it if newer, but I did this step anyhow), then you can go ahead and install on Win7 without the error. Ew.

    This probably isn't a problem for most people now, as they'll use installer, which doesn't error, with the patch applied so its actually certified for W7, but I've got a customer who've done all their testing against and want to roll with it, so there you go.

    thanks. Duncan

    Wednesday, August 31, 2011 11:45 PM
  • have you tried the following command

    sfc /scannow

    must be run as an administrator. open command prompt (right click run as administrator) and it will want to restart and that may just fix the issue it did for my Photoshop psapi.dll error.

    lan admin

    Thursday, February 09, 2012 8:57 PM
  • This one is the best solution. Just to add into this after coping PSAPI.dll into temp installer folder we must make it read only. I tried without making it read only and failed a few times. Hence concluded that it is must to make it read only.

    Thanks everyone for the inputs.


    Thursday, May 29, 2014 4:54 AM