locked
Crystal Report Viewer not rendering in browser RRS feed

  • Question

  • User-1078128378 posted

    Hi All,

    I am Using vs 2010 , Crystal reports for visual studio 2010 and windows-7 64 bit os.

    I Created an asp.net application it contains crystal reports.

    previously All Crystal Reports are worked fine.

    few days back i installed visual studio 2015 community edition. after that my crystal reports are not rendered in browser it is showing just empty screen, and i checked in debug mode Every code is working fine and it is not throws any exception.

    so i thought vs 2015 community edition causes error so i removed vs 2015.

    again i checked,but  crystal reports are showing just empty screen.

    i checked in developer tools console it shows following file are missing.

    how can i show crystal reports in browser.

    Thanks,

    Wednesday, December 30, 2015 6:22 AM

Answers

  • User-483542706 posted

    Hi Murali,

    I had the same problem when i installed vs 2015 comunity which i m sort out lately.

    first of all run the site on debug mode.

    then rightclick the report viewer and goto page source.  there will be a code like this. in my case 

    <script src="../aspnet_client/system_web/4_6_81/crystalreportviewers13/js/crviewer/crv.js" type="text/javascript"></script>

    then goto the following derectory 
    "C:\inetpub\wwwroot\aspnet_client\system_web"
    check for folder '4_6_81' if there is not a folder like that create new folder
    and name it.

    then open a folder '4_0_30319' or '2_0_50727' then copy all content and paste it into the created folder.

    not working so far copy and paste
    4_6_81 into the project directory


    happy coding

    Smile

    
    


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 2, 2016 9:37 AM
  • User-1078128378 posted

    Hi Witty ,

    I reinstalled Crystal Reports then my Problem Sloved

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, April 2, 2016 6:26 AM

All replies

  • User-2057865890 posted

    Hi,murali

    SAP Crystal Reports, developer version for Microsoft Visual Studio can be used with Visual Studio 2010 to 2013 as well as Visual Studio 2015.

    Install the Crystal report service Pack 15

    Based on the error message, please check whether js file exists or in the correct folder.

    Best regards,

    Chris Zhao

    Thursday, December 31, 2015 5:10 AM
  • User-1078128378 posted

    Hi Chris Zhao,

    Thanks for the reply

    but i did not find following path in my project

    http://localhost:51087/aspnet_client/system_web/4_0_30319/crystalreportviewers13/js/crviewer/images/style.css Failed to load resource: the server responded with a status of 404 (Not Found)

     i am not maintans any aspnet_client/system_web like that folders, even that previously it worked fine but now it is not working.

    where can i check those paths exists in project?

    Thanks,

    Thursday, December 31, 2015 5:18 AM
  • User-483542706 posted

    Hi Murali,

    I had the same problem when i installed vs 2015 comunity which i m sort out lately.

    first of all run the site on debug mode.

    then rightclick the report viewer and goto page source.  there will be a code like this. in my case 

    <script src="../aspnet_client/system_web/4_6_81/crystalreportviewers13/js/crviewer/crv.js" type="text/javascript"></script>

    then goto the following derectory 
    "C:\inetpub\wwwroot\aspnet_client\system_web"
    check for folder '4_6_81' if there is not a folder like that create new folder
    and name it.

    then open a folder '4_0_30319' or '2_0_50727' then copy all content and paste it into the created folder.

    not working so far copy and paste
    4_6_81 into the project directory


    happy coding

    Smile

    
    


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 2, 2016 9:37 AM
  • User144179983 posted

    Hi ,

    I am facing same issue and trying to find solution from last 3 days without any luck.

    In my case ,  

    <script src="../aspnet_client/system_web/4_0_30319/crystalreportviewers13/js/crviewer/crv.js" type="text/javascript"></script>

    Could you please help me to come out from this.

    Thanks
    Tuesday, March 22, 2016 8:14 AM
  • User-1078128378 posted

    Hi Witty ,

    I reinstalled Crystal Reports then my Problem Sloved

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, April 2, 2016 6:26 AM