locked
Debugging over ethernet still doesn't work RRS feed

  • Question

  • Hi,
    I did exactly the same way mentioned here but still I have issues connecting to the device. I have VS 2005 SP1.

    Steps followed

    1. Copy all the platform related files from 'C:\Program Files\Common Files\Microsoft Shared\CoreCon\1.0\Target\wce400\armv4i" namely
    - clientshutdown.exe
    - CMAccept.exe
    - ConmanClient2.exe
    - DeviceDMA.dll
    - eDbgTL.dll
    - TcpConnectionA.dll

    2. Change settings in VS 2005 for the device (SDK) to use a fixed ip address (which is configured in the eboot of device also. DHCP and VMINI are disabled in the device). Uncheck using a fixed IP address.
    3. Launch ConmanClient2.exe
    4. Launch CMAccept.exe
    5. Try connecting in another VS 2005, which didn't work. It only shows connection failed message.

    Firewall is disabled on the device.
    Host PC firewall can not be disabled because of group rules (Also tried adding exception for port 5655 - but didn't work)

    I can ping to the device with the ip address. But  telnet fails to open the connection. (telnet <ipaddress> 5655). Greatly appreciate help!
    Tuesday, May 5, 2009 12:22 AM

Answers

  • >>Try connecting in another VS 2005

    Try using the same instance of VS 2005 instead. Please refer to the "To set security and establish the connection" segment of the following guide:

    How to: Connect to Windows CE Device Without ActiveSync
    http://msdn.microsoft.com/en-us/library/ms228708(VS.80).aspx


    Please mark the post that helps you, and unmark that does not. This benefits our community members.
    • Marked as answer by warrentang Monday, May 11, 2009 1:42 AM
    Thursday, May 7, 2009 6:01 AM