locked
How do I get rid of the "Visual Studio 2010" folder in My Documents?

    Question

  • Hi everyone.

    Every time it runs, Visual Studio creates a folder called "Visual Studio 2010" in the "My Documents" folder. I don't want it there.

    Question 1: Is there anything I can do about it?

    Question 2: What is Microsoft's best practice policy on proper use of the file system? I'm a programmer, and I've always understood that storing application data in My Documents was taboo. However, Microsoft is clearly doing it, so it makes me scratch my head and wonder if I'm organizing my applications' files correctly. What's the logic here?

    -TC

    Friday, August 03, 2012 10:49 PM

All replies

  • To Question 1:

    In Visual Studio, go to Tools.

    a.) in Tools check "Show All Settings".

    b.) Tools > Options > Projects and Settings > General. Set the three locations as desired.

    To Question 2:

    Only for me!

    To make it as easy as possible, I always use my Applications folder. If necessary, I create a myprojects folder below, or downloadedModules etc.

    Saturday, August 04, 2012 12:46 AM
  • moskito-x,

    Regarding Question 1:

    Please confirm that your solution works for you. I tried it, and it doesn't work for me. (When I go to Tools > Options > Projects and Settings > General and set the three locations, Visual Studio continues to create a "Visual Studio 2010" folder in My Documents.)

    Regarding Question 2:

    When I put everything in the application folder, things work fine in XP, but fail badly in Windows 7 because of user privileges problems. How do you avoid those problems? (Or do you?) I also have privilege problems when I try to use the ProgramData folder. My question, however, was really about whether or not Microsoft has documented their recommendations for where to store files. My impression is that they designed a system that made sense, but nobody used it, so Microsoft's attitude now is "Screw it. Just put your files in the My Documents folder."

    -TC

    Sunday, August 05, 2012 4:30 PM
  • I'm on XP and I copy all Folders from C:\Dokumente und Einstellungen\Administrator\Eigene Dateien\Visual Studio 2010 to

    Y:\Programme\VisualStudio100\dtx

                          Backup Files
                          Code Snippets
                          Projects
                          Settings
                          StartPages
                          Templates
                          Visualizers

    all new Proj. created now in the new "Y:\Programme\VisualStudio100\dtx\Projects" folder.

    I'm not sure : On Windows7 you can try "H:\path\to\new\Projects".

    Monday, August 06, 2012 11:15 PM
  • Hi,

    just a few points I experienced in the past:
    a) Putting projects on a shared drive (y:\ seems like a mounted drive) can be a bad practice. The location might not be trusted so when debigging your project you might run into trouble.

    b) Files that your application manages should not be placed inside the "My Documents" folder. That is correctly. This folder is for user documents. From my point of view, my projects are my documents. Visual Studio is used like MS Word: I create documents with it and save them, where I want to. But of course: There is other stuff that does not belong in there e.g. Templates and such stuff. That are no user documents. So I can fully understand that you are not happy with this solution.

    c) Another point that is important in my eyes in this discussion is: It is posisble to have roaming proviles where data from the user profile is copied around. In such a case you have multiple mechanisms working on the same stuff that I simply do not like:
    My source is managed through source control (In my case I am using TFS). I do not want anything else to copy around my source code because it is simply not required - I got a better solution for that!

    d) I simply ignore these folders in my documents. So sorry - I do not have a solution for your main question.

    With kind regards,

    Konrad

    Tuesday, August 07, 2012 8:05 AM
    Moderator
  • Your "My Documents" does not need to point to a folder called "My Documents" Under properties, you can set the save location to any folders on any mounted drives to which you have access.

    Under Tools->Options->Projects and Solutions, you may set the folder locations to your preferred location. As mentioned somewhere in this thread, there are 3 locations: 1-Projects location 2-Project templates location and 3-Item templates location.

    As an added measure, though I have to put out the disclaimer here, back up your registry, then search for any instances of Visual Studio 2010Projects. I replaces mine with my projects folder and now, when I open a file with VS, no folders get created. Again, make sure you have backed up your registry and 2, perform this at your own risk.

    For mapped drives, if you do get a warning about debugging from an untrusted source, make sure you run VS as administrator.

    • Edited by Louie.Medina Wednesday, August 15, 2012 2:45 PM Added information
    Wednesday, August 15, 2012 2:39 PM
  • Louie,

    Thank you for the advice. However, it doesn't seem to be working for me. I changed all folder locations under Tools->Options->Projects and Solutions; then I went into the registry and changed every occurrence of "...\Documents\Visual Studio 2010" to something else. Nevertheless, Visual Studio still recreates the unwanted folder in My Documents every time it opens. Can you confirm that this solution worked for you? Was there another step, perhaps?

    -TC

    Friday, August 17, 2012 3:25 PM
  • Question 1: Yes, you can modify the registry entries that control the settings. Most are in "HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0" but there is one last on in "HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0_Config\Initialization" that sets the directory name that will be added automatically to %USERPROFILE%\Documents

    Question 2: Not sure I know the best practice to this process.

    Good, luck


    Shawn Gibbs

    Wednesday, December 19, 2012 1:19 PM