none
Can VS2008 application works on machine only having vs 2010 RRS feed

  • Question

  • Hi friends,

    Can VS2008 developed application works on machine only having vs 2010?

    Thanks,

    Nagarajan Govindarajan.

    Wednesday, September 1, 2010 11:46 AM

Answers

  • If the machine only having framework 3.5 and trying to load VS 2010 application

    - Not supported scenario and program will fail.

    If the machine only having framework 4.0 and trying to load VS 2008 application

    - Not recommended, as .NET 4.0 has a new and different CLR contrasted with previous versions. but you can and need to explicitly config the SupportedRuntime in app.config file.

    Thanks.


    Figo Fei


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Figo Fei Wednesday, October 13, 2010 3:02 AM
    Wednesday, October 13, 2010 3:01 AM
  • Yes.

    The programs doesn't need to install VS.

    They need to >Net frameWork.

    And because VS2008 >net is older than VS2010 .Net, They run normally.

    • Proposed as answer by Fix Soft Director Thursday, September 2, 2010 11:33 AM
    • Marked as answer by Figo Fei Wednesday, October 13, 2010 2:56 AM
    Thursday, September 2, 2010 11:33 AM

All replies

  • Yes.

    The programs doesn't need to install VS.

    They need to >Net frameWork.

    And because VS2008 >net is older than VS2010 .Net, They run normally.

    • Proposed as answer by Fix Soft Director Thursday, September 2, 2010 11:33 AM
    • Marked as answer by Figo Fei Wednesday, October 13, 2010 2:56 AM
    Thursday, September 2, 2010 11:33 AM
  • Hi Thanks,

    So it needs framework 4.0, otherwise it wont work right ?

     

    Rgds

    Nagarajan Govindarajan

    Friday, September 3, 2010 5:47 AM
  • Also

    what will happen

    If the machine only having framework 3.5 and trying to load VS 2010 application

    If the machine only having framework 4.0 and trying to load VS 2008 application

    Thanks,

    Nagarajan Govindarajan.

     

    Friday, September 3, 2010 8:01 AM
  • If the machine only having framework 3.5 and trying to load VS 2010 application

    - Not supported scenario and program will fail.

    If the machine only having framework 4.0 and trying to load VS 2008 application

    - Not recommended, as .NET 4.0 has a new and different CLR contrasted with previous versions. but you can and need to explicitly config the SupportedRuntime in app.config file.

    Thanks.


    Figo Fei


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Figo Fei Wednesday, October 13, 2010 3:02 AM
    Wednesday, October 13, 2010 3:01 AM