none
unable to type > (grater than)

Answers

  • Hi Vaclav and all reading this thread

    This is a bug introduced in Visual Studio 2015 Update 2.

    The root cause for this bug was the introduction of a new command in Visual Studio 2015 Update 2 to allow you to invoke quick actions/refactorings just for the position of your caret on a line (providing keyboard users with requested parity with the mouse lightbulb experience which lets you see fixes for just the hovered issue/squiggle).

    Unfortunately, the keyboard shortcut chosen, whilst logical, clashes with the one being used in some keyboards to achieve the “>” character, as you have found.

    We are working on a fix which will require a different keyboard shortcut for this feature; this is planned for the next update to Visual Studio.

    To work around the problem in the meantime, you can simply un-map or re-map the problem command in Tools-Options-Keyboard. Locate the EditorContextMenus.CodeWindow.QuickActionsForPosition command and Remove or remap it to your needs

    Thanks
    Mark Wilson-Thomas
    Program Manager, Visual Studio Editor Team


    Mark Wilson-Thomas Program Manager, Visual Studio Editor Team

    Friday, April 22, 2016 12:16 AM

All replies

  • The same effect normally happens when you type ‘Ctrl+.’, which is ”Quick Action”. Check this option: Tools à Options à Keyboard à”View.QuickActions”. It should be ‘Ctrl+.’. Also make sure that your Shift key is not mixed up with Ctrl. Try typing ‘>’ in Notepad, for example.

    Monday, April 18, 2016 6:01 PM
  • The setting is OK (View.QuickActions). In notepad I can type > normally.

    As I said, the problem occurs after the install of Update 2.


    Vaclav

    Monday, April 18, 2016 6:41 PM
  • Hi vjedlicka,

    According to your screenshot, I create a default C++ project with my Visual Studio Enterprise 2015 with Update 2 and type the same code in my project, the ">" can be input normally.

    Please try type the ">" in notepad and then copy it into your C++ project file. Does is can be past into the C++ project file?

    Then please create a new C++ project/other development language project to check whether this problem occurs with this specific project/project type.

    If new project works fine, please try move your original project files to the new project one by one to confirm which file causes this problem.

    If all project has this issue, please try with following steps to troubleshoot this problem.

    1. Run Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    2. Close all third part software when running Visual Studio, such as antivirus software.
    3. Reset all settings for your Visual Studio by menu Tools -> Import and Export settings -> Reset all settings.
    4. Repair your Visual Studio through Control Panel -> Programs and Features -> Visual Studio 2015 -> Change -> Repair.

    In addition, to make sure this problem is caused by Update 2, please uninstall the Update 2 from Control Panel -> Programs and Features -> View Installed Updates. Then retry again.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Tuesday, April 19, 2016 5:31 AM
    Moderator
  • Hi Weiwei,

    Thank you for your efforts. None of the steps suggested helped. After uninstalling "Update 2", I could not launch VS (it crashed). 

    I had to restore the C: drive from a restore point. Now VS runs fine with "Update 1", I can enter the > character.


    Vaclav

    Tuesday, April 19, 2016 10:15 AM
  • Hi vjedlicka,

    Since you have confirmed this problem is caused by the Update 2, I suggest you submit this issue to Visual Studio Connect and then share the feedback link here. It is benefit to other communities who has the same problem to vote and add comments for your feedback.

    I think the report team experts will treat this problem seriously and if any updates for this issue, they will send email to you. Thanks for your feedback for Visual Studio Product.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Wednesday, April 20, 2016 2:37 AM
    Moderator
  • Hi Vaclav and all reading this thread

    This is a bug introduced in Visual Studio 2015 Update 2.

    The root cause for this bug was the introduction of a new command in Visual Studio 2015 Update 2 to allow you to invoke quick actions/refactorings just for the position of your caret on a line (providing keyboard users with requested parity with the mouse lightbulb experience which lets you see fixes for just the hovered issue/squiggle).

    Unfortunately, the keyboard shortcut chosen, whilst logical, clashes with the one being used in some keyboards to achieve the “>” character, as you have found.

    We are working on a fix which will require a different keyboard shortcut for this feature; this is planned for the next update to Visual Studio.

    To work around the problem in the meantime, you can simply un-map or re-map the problem command in Tools-Options-Keyboard. Locate the EditorContextMenus.CodeWindow.QuickActionsForPosition command and Remove or remap it to your needs

    Thanks
    Mark Wilson-Thomas
    Program Manager, Visual Studio Editor Team


    Mark Wilson-Thomas Program Manager, Visual Studio Editor Team

    Friday, April 22, 2016 12:16 AM