none
2-Port USB 3.0 PCI Express Card connection problem RRS feed

  • Question

  • I have problem with 2-port USB 3.0 PCI Express Card connection. 2 days later I update driver and Kinect V2 stop working. But I test in my Laptop Kinect worked normal. So problem is USB 3.0 driver. 

    Here is my device manager. Other interesting fact that when I connect Kinect V2 USB in my PC, windows recognize it and showed me connection message.

    Please guys, have someone problem like this or can someone give me idea how to solve? Thank you. 

    Wednesday, July 8, 2015 9:04 PM

All replies

  • Was there any particular reason why were you updating the driver? Revert back to Microsoft provided driver. According to the posts in different threads it should help.
    Thursday, July 9, 2015 9:12 AM
  • Yes there was problem with Tobii device connection. It use USB 3.0 too. With old driver only I could work with Kinect V2. So I update driver. I must use Tobii and Kinect V2 in one project.  
    Thursday, July 9, 2015 9:28 AM
  • Here are some suggestions you could try and see if it resolves the issue:

    1. Unplug Kinect for Windows sensor

    2. Uninstall Kinect for Windows SDK and reinstall it.

    3. Plug the Kinect for Windows sensor

    4. Run the Kinect v2 Configuration Verifier tool. Ensure you see success with this tool. Sometimes you may not be connected to the correct PCIx Gen 2.0 of the motherboard so the sensor can get enough bandwidth.

    5. Can you connect the two devices to different USB 3.0 controllers?


    Monday, July 13, 2015 7:49 PM
    Moderator
  • Thank you for information. I did as you said. Here result.

    1. First time I uninstall and install it gave me this error. I tried second time. 


    Monday, July 13, 2015 9:47 PM
  • This time I show installation ok, but I couldn't find by default projects and editor. And Kinect didn't work. But second device with USB 3.0 is working.

    Monday, July 13, 2015 9:51 PM
  • Could you please share the log files from the "Setup logs location"?

    They should be called something like:

    Kinect_for_Windows_SDK_v2.0_1409_<timestamp>

    Kinect_for_Windows_SDK_v2.0_1409_<timestamp>_0_x64Runtime


    Monday, July 13, 2015 9:59 PM
    Moderator
  • Make sure you tried to connect the 2 devices on different USB 3 controllers. That way you have enough bandwidth for the Kinect Sensor.


    Monday, July 13, 2015 10:05 PM
    Moderator
  • Here all log file in one folder. And please look my device manager how recognize Kinect.

    https://drive.google.com/folderview?id=0Bza1qpcDXH7Nfk9yM1ZPQTA1NUlNZG1MMWZTejI5S29UQVFUUEF2QkRNUEgxeGw2NnhpM3c&usp=sharing

    Monday, July 13, 2015 10:12 PM
  • The device manager does not look right. It should not recognize the Kinect Sensor as an Android Device.

    Might I suggest reimaging the machine and starting over?



    Monday, July 13, 2015 10:24 PM
    Moderator
  • I disconnect Kinect device, restarted computer, uninstall Kinect SDK, restarted one more time. Here device manager without sdk picture.

    Device Manager without SDK

    After that I install SDK. But device manager is the same and Kinect doesn't work. But second device which use USB 3.0 work fine.

    Monday, July 13, 2015 10:50 PM
  • Another thing to try:

    Disconnect device, uninstall Kinect SDK, restart.

    Connect device, go to Device Manager and right click on the Xbox Sensor in the device manager and click Update driver. This should get you the latest driver and runtime.

    Ensure its enumerated correctly in the device manager and then install K4W SDK.


    Monday, July 13, 2015 11:43 PM
    Moderator
  • I did as you told, but it couldn't find driver online. 
    Tuesday, July 14, 2015 2:02 PM
  • Vardan, is reimaging the machine and starting over an option for you?

    What is the difference between the machine that works and the one that does not work?



    Tuesday, July 14, 2015 4:26 PM
    Moderator
  • I will try format my computer. But I think problem will be. 

    What means work and does not work - When my Kinect I connect with Laptop it works great. When I connect with Personal Computer, I use here USB 3.0 PCI Express Card as I show you. In this card I have 2 USB 3.0.

    Now second device work great, but Kinect doesn't work. In Kinect adapter Blue and Green lights works, when I connect USB 3.0 in PCI Express Card Windows recognize that Kinect connected, but when I open any project Kinect Browser, it print that Kinect doesn't available.

    This problem I get when I update USB 3.0 Express Card, in that time I had problem with second device, but with old driver it work normal. 

    Tuesday, July 14, 2015 4:37 PM
  • Hello Neeraj Wadhwa,

    Thank you for so hard work. As you told me, I formatted my PC, but after it I have the same problem.

    1. Second device which use USB 3.0  work normal.

    2. Kinect V2 doesn't work.

    Here Screen Picture

    Problem is Kinect V2 driver. Please, are there any other developer that can be useful me. This project is PhD dissertation, please I have deadline and must solve problem.

    Thank you ))))

      

    Wednesday, July 15, 2015 8:55 PM