locked
Using SignalR as application Extension Produces Error RRS feed

  • Question

  • User-1458511794 posted

    I am extending a commercial C#.Net  web service with custom C#.Net DLLs.   The vendor also provides an ASP.Net/C#.Net  management console which allows me to manage my custom objects.  So, my custom DLLs are shared with both the vendor's window's service and  management console as shown below.

                            Vendor ASP.Net Management Console -> Loads My DLLs          Vendor C#.Net Windows Service -> Calls methods on my DLLs

    When I don't use signalR everything works OK.  When I use signalR, I need to update the App.Config for the Windows Service and the Web.Config for the ManagementConsole to have this line.

    <add key="owin:AutomaticAppStartup" value="false" />

    In this configuration almost everything works fine, except on one ASP.Net page in the Management Console, I get the error below.  Can you give me some insight into what would cause SignalR to report error? And recommendations would also be appreciated.  (I realize this question will also require a discussion with the 3rd party app vendor.)

    Error:             Unable to find control with id 'asTxtowin:AutomaticAppStartup' that is associated with the Label ''.    

    Stack Trace: at System.Web.UI.WebControls.Label.AddAttributesToRender(HtmlTextWriter writer) at System.Web.UI.WebControls.WebControl.RenderBeginTag(HtmlTextWriter writer) at System.Web.UI.WebControls.WebControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.WebControls.WebControl.RenderContents(HtmlTextWriter writer) at  ...        

    Friday, October 9, 2015 9:40 AM

All replies

  • User61956409 posted

    Hi monica_barback,

    Error:             Unable to find control with id 'asTxtowin:AutomaticAppStartup' that is associated with the Label ''.  

    Have you debugged your code to find which line of code that causes the error? Besides, please make sure whether it has a control with id 'asTxtowin:AutomaticAppStartup'.

    Best Regards,

    Fei Han

    Monday, October 12, 2015 1:41 AM