The following forum(s) have migrated to Microsoft Q&A (Preview): Azure Virtual Machines!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

How to fix failed VMSS deployment with error “unknown network allocation error” RRS feed

  • Question

  • I am trying to deploy a 3-tier architecture to Azure using the Azure PowerShell CLI and a customized ARM template with parameters. I am not having any issues with the powershell script or the template's validity.

    Within the template, among other things are two Virtual Machine Scale Sets, one for the front-end and one for the back-end. Front-end is windows and back-end is red hat. The front-end is behind an application gateway while the back-end is behind a load balancer. What's weird is that the front-end VMSS is deploying no problem and all is well. The back-end VMSS fails every time I try to deploy it, with a vague "Unknown network allocation error" message that I have no idea how to debug (since it provides no specifics unlike all of my other error messages so far).

    I based the ARM template on an exported template from a working model of this architecture in another resource group and modified the parameters and have spent a while cleaning up issues and errors with Azure's exported template. I have tried deleting and starting from scratch but it doesn't seem to fix this problem. I thought it was possible I reached the limit of free-subscription processors so I tried making the front-end VMSS dependent on the back-end VMSS so the back-end VMSS would be created first, but the same issue still happened.

    I expected them to both behave similarly. Granted, back-end is RH linux while front-end is windows, and the front-end is behind an application gateway while the back-end is behind a load balancer, but this setup is working perfectly fine in my other resource group that was deployed through the portal instead of through ARM. But every time I try to deploy this I get an error.  

    I have tried making it in a completely new resource group in a new region (centralus instead of westus2) with no change to the error.

    I would post the code of my templates but despite my message only being <30,000 characters I keep getting an error submitting this post saying it has to be between 4 and 60,000 characters, so I guess I can't post the templates?  I tried to put them on github and link them but apparently I am not allowed to post links either.

    Replace the spaces with periods to get the URLs for the portions of the templates:

    Back-end (problem) portion of template:

    For reference to see the difference, Front-end (no problem) portion of template:

    Wednesday, May 15, 2019 8:25 PM

All replies

  • First thing I would try is deploying a VMSS from out sample repo or via the portal. This will narrow down if the issue is with your template, or something limited with your subscription. If you are running a free trial subscription you only get 4 cores to work with. So that could be hard to deploy two scalesets with.

    Wednesday, May 15, 2019 10:33 PM
  • Hmm looks like I got the same error when deploying it through the portal.  I figured since I only had 2 existing VMSSs in my subscription (with only 1 instance each), and my script is only creating 2 more VMSSs (also starting with only 1 instance each), that that would keep me at 4 and I would be ok.

    So is the problem then that the free trial subscription isn't allowing me to have 4 single-instance VMSSs because then they wouldn't be able to scale?  I'm just trying to make them to test out my ability to make this kind of architecture.  Is there any way to find out for certain if the subscription-limit is what's causing my problem?

    Wednesday, May 15, 2019 11:10 PM
  • It could also possibly be an issue with selecting the B series for the VM size. This size is our burstable sizes and you can accumulate credit. Have you tried some of the A series instead? 
    Wednesday, May 15, 2019 11:19 PM
  • Okay I tried creating one with A0 size (sorry it took me so long, had to then troubleshoot issues with it not supporting premium disks and for some reason was taking a long time to deploy).  Once I got the issues sorted out I ran into the same error.
    Thursday, May 16, 2019 5:52 PM
  • Thanks for giving that a go. Figured it was worth checking at least :) 

    Hard to say exactly what the issue is without looking at the backend logs. I assume it has something to do with being on a free trial subscription and some quota issues. However, generally the error message I see with quota issues is different. 

    I think it would be best to get you in touch with Support to look at the backend and help get this sorted out. Can you email me at and provide me with your Azure SubscriptionID and link to this thread. I can enable your subscription for a free support request. 

    Thursday, May 16, 2019 6:39 PM
  • Any update on this issue? 
    Friday, May 31, 2019 7:17 PM