locked
Task list creating automatically when I save a workflow RRS feed

  • Question

  • I have some very strange behavior with WSS3.0 and workflow.

    I have an annoucement type list called "Tasks".  I used the annoucement type when I created it because that type allows me to email enable the list.  But really I just wanted a custom list. 

    Anyway, when I save a workflow (or re-save), sharepoint automatically creates a Task type list, and names it "Tasks 1" (apparently it would call it "tasks" but is unable because I already have a list with that name). 

    It does NOT associate the workflow with that list directly.  It's an empty list as if someone created a new Tasks list and didn't touch any of the setting, with one distinction... This new task list has one extra column called "Workflow Name" (single line of text) which isn't a normal part of a Tasks type list.  And that column is not in the forms.  But when you look at workflow settings it says that there is no workflow associated with the list. 

    And in fact, workflow that I'm creating are generally working on the list I do create it for.  I'm having one problem detailed here, but in general they do work.  However if I delete the strange dynamically created list, the workflows stop working. 

    If I create an item in my list, let the workflow fire, and then look at the workflow status for that item, there are references to this other dynamically created "Tasks 1" list.  When I delete the strange list and go look again at the workflow status of my list, it refers to the list as missing. 

    I'm not finding anything where this has happened in other areas.  Is this strictly an issue of my having given my list the name "Tasks"??

    Friday, March 30, 2012 6:13 PM

Answers

  • Hi,

    SharePoint works that way, and yes it is due to the name. You can try and change it, and see if it works. By default it creates the lists with numbers like Lists/List1... +n.

    Cheers

    • Marked as answer by tmiller112 Wednesday, April 11, 2012 8:28 PM
    Thursday, April 5, 2012 10:40 AM